Search field in ctrl-tab panel is resized during focus/blur

VERIFIED DUPLICATE of bug 473153

Status

()

Core
Widget: Win32
--
minor
VERIFIED DUPLICATE of bug 473153
10 years ago
9 years ago

People

(Reporter: whimboo, Unassigned)

Tracking

Trunk
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b2pre) Gecko/20081105 Minefield/3.1b2pre

Setting the focus to the search field inside the ctrl-tab panel changes its size. Probably related to the empty text attribute?

Steps:
1. Open at least 3 tabs
2. Hit ctrl+tab to open the panel
3. Hit ctrl-f or click inside the search box

With step 3 the search box shrinks. Looks like a Windows only issue.

Comment 1

10 years ago
(In reply to comment #0)
> Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b2pre) Gecko/20081105
> Minefield/3.1b2pre
> 
> Setting the focus to the search field inside the ctrl-tab panel changes its
> size. Probably related to the empty text attribute?

Do you see the same with other search fields using emptytext?
Can you attach a screenshot of both states?
Component: Tabbed Browser → XUL Widgets
Product: Firefox → Toolkit
QA Contact: tabbed.browser → xul.widgets
(Reporter)

Comment 2

10 years ago
Created attachment 347057 [details]
Search field (focussed/unfocussed)

No, it's only visible in ctrl-tab. Other instances don't show this resizing.

Comment 3

10 years ago
What happens if you use the classic OS theme?
(Reporter)

Comment 4

10 years ago
Good hint. I switched to classic mode and it doesn't happen there. Looks like an Aero issue.

Updated

10 years ago
Blocks: 451300
Component: XUL Widgets → Widget: Win32
Product: Toolkit → Core
QA Contact: xul.widgets → win32

Updated

9 years ago
No longer blocks: 451300
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 473153
(Reporter)

Comment 6

9 years ago
Would be nice to re-use existing bugs as filing new ones and duping older bugs with more information to the newly one. Verifying for now.
Status: RESOLVED → VERIFIED
(In reply to comment #6)
> Would be nice to re-use existing bugs

I would have done this if I'd have remembered this bug.

This bug doesn't add much relevant information; the other one is more generic and has a testcase, hence the duping this way.
You need to log in before you can comment on or make changes to this bug.