Need a "View => Tab thumbnails" (or something) menu equivalent to Ctrl+Tab

VERIFIED FIXED in Firefox 3.6a1

Status

()

Firefox
Menus
VERIFIED FIXED
9 years ago
8 years ago

People

(Reporter: tonymec, Unassigned)

Tracking

({access})

Trunk
Firefox 3.6a1
access
Points:
---
Bug Flags:
blocking-firefox3.5 -
in-litmus ?

Firefox Tracking Flags

(Not tracked)

Details

Need a "View => Tab thumbnails" (or something) menu equivalent to Ctrl+Tab

This would be useful on any platform, but it is essential when using the KDE window manager on Linux, because in that case the Ctrl+Tab keychord is intercepted by the window manager to switch virtual desktops (by menu, go to next or previous virtual desktop every time Tab or Shift+Tab are hit while holding Ctrl), so no program getting its keys through X can ever see a Ctrl+Tab in that environment.

Updated

9 years ago
Flags: blocking-firefox3.1?
Keywords: uiwanted

Comment 1

9 years ago
Are you talking about a separate menu from the List All Tabs button on the right side of the tabstrip?
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b2pre) Gecko/20081105 Minefield/3.1b2pre - Build ID: 20081105020548

When I click that button, nothing happens, except that it becomes dark grey on a first click, then white again if I click again.

What I'm advocating is an additional menuitem in the View menu, on the menu bar.
P.S. It does work in a clean profile, but IMHO a menuitem on the menubar would still not be too much.

Comment 4

9 years ago
Agreed on the need of a menu item. As I recall, Dão's extension had some shortcut like Ctrl-Shift-A, but that's not working here. If there's another shortcut, it doesn't seem discoverable at all. So, as far as I can tell, the tab search feature is currently completely inaccessible if you don't use the mouse.
(In reply to comment #4)
> Agreed on the need of a menu item. As I recall, Dão's extension had some
> shortcut like Ctrl-Shift-A, but that's not working here. If there's another
> shortcut, it doesn't seem discoverable at all.

Ctrl-Tab -> Ctrl-F. Yes, not very discoverable.

Updated

9 years ago
Depends on: 465076
Keywords: uiwanted → access
This feature was removed from 3.1, so not blocking.
Flags: blocking-firefox3.1? → blocking-firefox3.1-
Fixed by bug 465076.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3.6a1

Updated

8 years ago
Duplicate of this bug: 487830
Verified with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2b3pre) Gecko/20091113 Namoroka/3.6b3pre (.NET CLR 3.5.30729) ID:20091113051922

Once this feature will be enabled by default we have to update the appropriate Litmus test for the View menu.
Status: RESOLVED → VERIFIED
Flags: in-litmus?
You need to log in before you can comment on or make changes to this bug.