Closed Bug 463407 Opened 12 years ago Closed 12 years ago

eMail notification dialog on attendee side after first minor event change is wrong

Categories

(Calendar :: E-mail based Scheduling (iTIP/iMIP), defect)

defect
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: andreas.treumann, Assigned: dbo)

Details

Attachments

(1 file)

TEPS TO REPRODUCE:
===================

- accept an iTip/iMip invitation
- the organizer add a description or change the title (minor change)
- the attendee gets the eMail notification
- push the 'Update' button  

RESULT:
=======

- the eMail notification dialog pops up 

EXPECTED RESULT:
================

- the attendee should only send out an eMail notification after major event changes

REPRODUCIBLE:
=============

- always


This happens only after the first minor change.
Attached patch fix - v1Splinter Review
I could only trigger the problem if
1) organizer sends out invitations
2) attendees respond
3) organizer does yet not update incoming replies from attendees, but sends out a minor updates, e.g. description change
4) attendee press update

The problem is that the attendee overwrites its partstat when updating (step 4).

This patches fixes that and adds more minor fixes:
- using calInstanceOf
- no calendar chooser on request updates
Assignee: nobody → daniel.boelzle
Attachment #346676 - Flags: review?(philipp)
Status: NEW → ASSIGNED
Comment on attachment 346676 [details] [diff] [review]
fix - v1

r=philipp
Attachment #346676 - Flags: review?(philipp) → review+
Pushed to comm-central <http://hg.mozilla.org/comm-central/rev/af90017a839b>

-> FIXED
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.0
Checked with lightning build 20081111050637 -> VERIFIED
Status: RESOLVED → VERIFIED
Target Milestone: 1.0 → 1.0b1
You need to log in before you can comment on or make changes to this bug.