Can't export bookmarks in HTML format any longer

RESOLVED DUPLICATE of bug 457441

Status

()

RESOLVED DUPLICATE of bug 457441
10 years ago
10 years ago

People

(Reporter: roeswin, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.3) Gecko/2008092417 Firefox/3.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.3) Gecko/2008092417 Firefox/3.0.3

Until a few days ago, I was able to export my bookmarks in HTML Format to my Computer. Now, it doesn't show up on my Desktop any longer. I am nopt sure what to do about it.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Note: Bugzilla is not for support, we have http//support.mozilla.com for that.

Do you have any bookmark addons installed ?
Can you download and save files from webpages ?
Do you saved something to a flash drive or other removeable disks and removed it ?

Does the Firefox safemode help ?
http://support.mozilla.com/en-US/kb/Safe+Mode
(Reporter)

Comment 2

10 years ago
No bookmark addons
Yes to downloading and saving on External Drives.
I have never used safemode. Irene
I didn't ask if you used the safemode in the past, i asked if you can try to follow the instructions in the URL an start Firefox in the Firefox safemode.

PLease also try this:;
Type about:config as URL in Firefox, confirm the warning, type "lastdir" in the filter box at the top of the page.
Does the directory of this string point to a non-existing path (removed drive) ?
In that case right click in the entry and select reset.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.3) Gecko/2008092417 Firefox/3.0.3

This works fine for me.
(Reporter)

Comment 5

10 years ago
I have done the about:config in URL and it showed as 
Status: User Set
Type: String
Value; c:\Documents and settings\HP_Administrator\My Documents

I also started Firefox in safemode and tried to export bookmarks but it would not do it in safemode either.
What's left? Should I reinstall Firefox at this point? Irene
If it works in the safemode then it can't be a addon problem.

You can create a new Firefox profile and import the bookmarks there if you have an older backup of your bookmarks.
http://support.mozilla.com/en-US/kb/Managing+profiles

I don't know what's wrong, could be a corrupted bookmark file that breaks the exporting....
(Reporter)

Comment 7

10 years ago
No, it didn't work in safemode either. Thank you for trying to help with this problem. Irene
I've heard another user on irc complaining about this recently, the problem is
trying in a fresh profile would be inconclusive as it probably is something in
the current bookmarks that the export is choking over.
Natch: That's the reason why I wrote that the current bookmark file might be broken and that it may break the export.

If it works in a new profile and with the imported bookmarks then you can be sure that this is either the bookmarks file or some prefernces setting.
A developer could analyze such a broken file but he would need the bookmark file but I don't expect from a reporter that he adds his bookmarks file to an open bug report.

Analyzing the Places SQL file with sqlite tools might help but I'm not sure if Irene can do such a task and I didn't do that myself before.
matti: What I meant was that they may be using a perfectly valid bookmark setup and the export function still chokes on it (on irc the backup bookmarks using json worked fine for that user), which is why, like you said, the actual file would have to be investigated...

Comment 11

10 years ago
Something seems to be broken in Firefox 3.0.3 and 3.0.4, there are many reports of this problem at both SUMO and MozillaZine.
http://forums.mozillazine.org/viewtopic.php?f=38&t=935255&start=30

There also seems to be a problem with restoring JSON backups for some users, so the two (HTML + JSON) might be related.
could you check with Sqlite manager add-on if you have any bookmarks that is missing moz_places entry?

the query to execute is:
SELECT id FROM moz_bookmarks b WHERE b.type = 1 AND NOT EXISTS (SELECT id FROM moz_places WHERE id = b.fk)

and this query should not return anything.

if the query contains anything this is a dupe of bug 457441
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 13

10 years ago
I am afraid Marco Bonardo, your suggestion is way over my head. I do not understand it. I am not that advanced. Do you think if i uninstalled and reinstalled Firefox it will solve the problem?
(In reply to comment #13)
> I am afraid Marco Bonardo, your suggestion is way over my head. I do not
> understand it. I am not that advanced. Do you think if i uninstalled and
> reinstalled Firefox it will solve the problem?

no, it won't solve the problem, nor will do my "suggestion". But we need to know that to apply/suggest a correct fix though.
Though i understand that could be difficult for a non technical user, how big is your places.sqlite?

Comment 15

10 years ago
Sorry, I don't know what my places.sqlite is and how to find that info. Irene
most likely a dupe of bug 457441.

With 3.0.5 you can try backup your bookmarks to JSON, restore them, then retry export to html. But you should really make a profile backup before trying that.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 457441
You need to log in before you can comment on or make changes to this bug.