Firefox 3.0.4 and Firebug 1.4a appear to be incompatible

RESOLVED INVALID

Status

()

RESOLVED INVALID
10 years ago
10 years ago

People

(Reporter: duncan.loveday, Unassigned)

Tracking

unspecified
x86
Windows XP
Points:
---
Bug Flags:
blocking1.9.0.5 -
wanted1.9.0.x -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.0.4) Gecko/2008102920 Firefox/3.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.0.4) Gecko/2008102920 Firefox/3.0.4

Some problems were noted whilst attempting to compare the size of a javascript performance hit with different versions of Firebug in bug 463669.

The intention here is to reproduce these problems starting with a clean profile and decide what is to be done

Reproducible: Always

Steps to Reproduce:
1. Test case to follow shortly
2.
3.
(Reporter)

Comment 1

10 years ago
OK, here it comes

(1) Firefox 3.0.4 from here http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/3.0.4-candidates/build1/firefox-3.0.4.en-US.win32.installer.exe

(2) Create two clean profiles, e.g. A and B. In both profiles set bugzilla.mozilla.org as the home page. I also set up my proxy script as I'm behind a firewall.

(3) In profile B only install Firebug 1.4a from here http://getfirebug.com/releases/firebug/1.4X/firebug-1.4X.0a1.xpi

(4) Now launch Firefox in profile A and B. For me, profile A behaves fine but profile B comes up with a corrupted tab.

(5) Try the same with www.google.co.uk instead of bugzilla. For me I get a blank tab in profile B.

(6) I have not today been able to reproduce a hang or crash but yesterday I definitely had it hanging. That was with multiple tabs open, some of which had an intranet app loaded so hard to provide an exact case.
(Reporter)

Comment 2

10 years ago
Created attachment 347062 [details]
Here's what I see when opening buzilla.mozilla.org
(Reporter)

Comment 3

10 years ago
This bug is specifically with Firefox 3.0.4.

Fine with 3.0.3.

Also, suspending Firebug does not help - it has to be completely uninstalled.
(Reporter)

Updated

10 years ago
Summary: Investigate problems with Fx 3.0.4 and Firebug 1.4a noted in bug 463669 → Firefox 3.0.4 and Firebug 1.4a appear to be incompatible

Comment 4

10 years ago
Honza, my first guess would be nsITraceableChannel exception causing the page processing to abort.  Are these listeners attached if net is disabled?

Duncan, can you open Firebug Icon (upper left) Firebug Tracing Console, options ERRORS and FBS_ERRORS, the look a the log for errors when you load one of the problem pages?

Updated

10 years ago
Blocks: 463669
yep, I can reproduce the problem with firebug-1.4X.0a1.xpi. This should be fixed in branches/firebug1.4 (head). I have tested it on my pc and it works (it was problem of wrong optimalization, which has been reverted, but it's presented in 1.4a1). 

John, could we build a2 so, it can be retested here?

I have to check yet, whether the listener is registered if net panel is disabled. However, I guess that the cache is necessary even for the script panel, right? So, it won't be perhaps so trivial.

Honza



Honza
(Reporter)

Comment 6

10 years ago
Can somebody clear something up for me - is it OK to raise and track bugs in Firebug here ? It's not a Mozilla product as such is it ?
It's not a huge problem, but it would be a bit better to have this kind of bugs discussed at: http://code.google.com/p/fbug/issues/list

IMHO bugzilla should be used in cases where Firebug is blocked by an issue coming from Mozilla APIs.

Honza
Firebug 1.4.0a2 is available at:
getfirebug.com/releases/firebug/1.4/

The a2 version should fix this bug.
Honza

Comment 9

10 years ago
You'll need either 1.4X.0a2 or 1.4.0a3, the detraced version of 1.4a2 is broken.
Just to be clear, this is an issue that Firebug is fixing and is not important for the Firefox 3.0.4 release. Correct?

Comment 11

10 years ago
Correct. I am running 3.0.4 + Firebug 1.4a3, and the issue is resolved.
Marking some flags so I don't come across this again. Can this bug be resolved as INVALID since the issue was with Firebug?
Flags: wanted1.9.0.x-
Flags: blocking1.9.0.5-

Comment 13

10 years ago
Yes, I would do the same to you ;-)
Could most likely be resolved because it seems to work with 3.0.4 + Firebug 1.4a3.
(Reporter)

Comment 15

10 years ago
I see this working fine with 3.0.4 and 1.4X.0a4.

Resolving as INVALID as requested since this was not an issue with Firefox.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.