Crashing on opening News Group Postings with images attached [@ nsNNTPProtocol::DisplayArticle]

RESOLVED WORKSFORME

Status

--
critical
RESOLVED WORKSFORME
10 years ago
8 years ago

People

(Reporter: mason.paul, Unassigned)

Tracking

({crash})

1.8 Branch
x86
Windows Vista
crash

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.0; SLCC1; .NET CLR 2.0.50727; Media Center PC 5.0; .NET CLR 3.0.04506; .NET CLR 3.5.21022; .NET CLR 1.1.4322)
Build Identifier: 2.0.0.17 (20080914)

I can open NG postings WITHOUT any images attached regardles of format, RTF, HTTP, etc.

BUT as soon as I try to open one with an image rgardles of that image format GIF, JPG etc CRASH

Reproducible: Always

Steps to Reproduce:
1.Star Thunderbird as usuall
2.Allow it to down load emails & update NGS
3.Got my NG, discussion.autodesk.com - autodesk.inventor
4. Select a Posting WITHOUT an attachment opens and read OK
5. Select a Posting, ANY posting that is, with an attachment and CARSH
Actual Results:  
1.Star Thunderbird as usuall
2.Allow it to down load emails & update NGS
3.Got my NG, discussion.autodesk.com - autodesk.inventor
4.Select a Posting, ANY posting that is, with an attachment

Expected Results:  
Postings wth out attachments open OK

Postings with attachments Crash the program

I should have been able to read the posting with the attachment, and SEE the attachment preview as per my setting, which have NEVER been changed.
(Reporter)

Comment 1

10 years ago
I've posted a test message with an attachment, that I know was accessable. I have tried to open that posting, after it appered in the list, with the attachment the program crashed.

I also sent the SAME message, to my self, at a secondary POP email address, BUT as an email with the same atachment. That openend with out any problem and with a preview of the attacment as per my preferances.
Duplicate of this bug: 463899
For crashes, we need the talkback crash id. See <http://kb.mozillazine.org/Talkback>

Do you still see it with a nightly/alpha?
<http://www.mozillamessaging.com/en-US/thunderbird/early_releases/>
(Reporter)

Comment 4

10 years ago
These are the "Talkback" crash Ids from 28/10/2008 @ 14.02 up till 11/11/2008 @ 03.27

TB51163008Z, TB51151362M, TB51149883M, TB51149729Z, TB51146175Y, TB51146123Y, TB51139602E, TB51137906X, TB51128344H, TB51127252Y, TB51118947M, TB51118577Z, TB51115673Z, TB51115424X, TB51114980Z, TB51114811W, TB51113629K, TB51113606G, TB51112206G, TB51112142Y, TB51111805G, TB51110706H, TB51109449H, TB51109182Z, TB51109062K, TB51109021Z, TB51098580X, TB51098551Y, TB51098060E, TB51098052X, TB51097912K, TB51097845Q, TB51097815Y, TB51084588W, TB50891784W, TB50886867W, TB50782989K, TB50782679E, TB50782420Z, TB50776937E, TB50773300M, TB50773287K

Comment 5

10 years ago
Incident ID: 51163008
Stack Signature	nsNNTPProtocol::DisplayArticle 5dae9263
Product ID	Thunderbird2
Build ID	2008091421
Trigger Time	2008-11-10 19:27:32.0
Platform	Win32
Operating System	Windows NT 6.0 build 6001
Module	thunderbird.exe + (0058c9bc)
URL visited	
User Comments	
Since Last Crash	14163 sec
Total Uptime	2094221 sec
Trigger Reason	Access violation
Source File, Line No.	e:/builds/tinderbox/Tb-Mozilla1.8-Release/WINNT_5.0_Depend/mozilla/mailnews/news/src/nsNNTPProtocol.cpp, line 2478
Stack Trace 	
nsNNTPProtocol::DisplayArticle  [mozilla/mailnews/news/src/nsNNTPProtocol.cpp, line 2478]
nsNNTPProtocol::ReadArticle  [mozilla/mailnews/news/src/nsNNTPProtocol.cpp, line 2501]
nsNNTPProtocol::ProcessProtocolState  [mozilla/mailnews/news/src/nsNNTPProtocol.cpp, line 5009]
nsMsgProtocol::OnDataAvailable  [mozilla/mailnews/base/util/nsMsgProtocol.cpp, line 350]
Component: Account Manager → Networking: News
Keywords: crash
Product: Thunderbird → Core
QA Contact: account-manager → networking.news
Summary: Crashing on opening News Group Postings with images attached → Crashing on opening News Group Postings with images attached [@ nsNNTPProtocol::DisplayArticle]
Version: unspecified → 1.8 Branch
(Reporter)

Comment 7

10 years ago
RE coment #6

I havent a clue what you mean. I don't speak programmer just mechanicla enginer
(Reporter)

Comment 8

10 years ago
I have forwadrd comment #6 to the techies at Autodesk, which is the News Group that I'm having the problems with JUST incase it is tere fault. NOT THAT THEY'LL ADMIT IT if it is
Hmm, the actual situation is a bit more complicated: nsMsgLineBuffer should be setting pauseForMoreData to true if it returns null; the only cases where it isn't doing that is when growing the array fails or when the available call fails.

The code in general is bad also since we're doing fun things like putting -1 into an unsigned integer...

Confirming since there are talkback IDs.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 10

10 years ago
I thought intiger had to be positive whole numbers, mind it 25 years since I did anything in that way of things.
(Reporter)

Comment 11

10 years ago
So is the problem caused by a BUG in the NNTP servers programming or is it in thunberdird (which I doubt)??
(Reporter)

Comment 12

10 years ago
(In reply to comment #9)
> Hmm, the actual situation is a bit more complicated: nsMsgLineBuffer should be
> setting pauseForMoreData to true if it returns null; the only cases where it
> isn't doing that is when growing the array fails or when the available call
> fails.
> The code in general is bad also since we're doing fun things like putting -1
> into an unsigned integer...
> Confirming since there are talkback IDs.


is the problem caused by a BUG in the NNTP servers programming or is it in
thunberdird (which I doubt)??
(In reply to comment #9)
> The code in general is bad also since we're doing fun things like putting -1
> into an unsigned integer...

Since the crash is down at 

  if (line_length > 1 && line[0] == '.' && line[1] == '.')

... and the unsigned line_length is set to -1 in one error case, I wonder if that's not exactly what is causing the crash.
(Reporter)

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED

Comment 14

10 years ago
No bug or patch identified as the fix.  (Or any explanation.)
Resolution: FIXED → WORKSFORME
(Assignee)

Updated

10 years ago
Product: Core → MailNews Core
(Reporter)

Comment 15

10 years ago
It apperars that Thunderbird is NOT able to handle the error caused/reported back from the AutoDesk or any other NEws Group servers in the same way as other NNTP programs can that being with a simple error message and then contiue with out crashing.
(Reporter)

Comment 16

10 years ago
As for resolved worksforme it will do this late on as the problem on the news server was corrected some time ago a lot quicker that any problems with Thunderbird are.
Crash Signature: [@ nsNNTPProtocol::DisplayArticle]
You need to log in before you can comment on or make changes to this bug.