Memory leak in cert printing.

RESOLVED DUPLICATE of bug 459237

Status

NSS
Tools
P3
normal
RESOLVED DUPLICATE of bug 459237
9 years ago
9 years ago

People

(Reporter: Slavomir Katuscak, Assigned: Alexei Volkov)

Tracking

trunk
3.12.2
Sun
Solaris

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
Memory leak found in vfychain tests on machine communist (uses extra settings  NSS_ENABLE_PKIX_VERIFY=1 and PKIX_OBJECT_LEAK_TEST=1)

Block in use (biu):
Found block of size 10428 bytes at address 0x6aec0 (91.41% of total)
At time of allocation, the call stack was:
    [1] get_zone() at 0xdcd682bc
    [2] getsystemTZ() at 0xdcd683f8
    [3] mktime() at 0xdcd65794
    [4] __strftime_std() at 0xdcde3a7c
    [5] PR_FormatTime() at 0xe452c078
    [6] secu_PrintTime() at 0x18790
    [7] SECU_PrintUTCTime() at 0x1881c
    [8] secu_PrintValidity() at 0x1a418
    [9] SECU_PrintCertificate() at 0x1d9f0
    [10] SECU_PrintSignedData() at 0x1f244
    [11] SEC_PrintCertificateAndTrust() at 0x1f324
    [12] main() at 0x164c4

I don't have information about files/lines yet, because data are from OPT build (DBG build was hanged, I restarted it now).
(Reporter)

Comment 1

9 years ago
Adding stack to list of ignored files:
vfychain/main/SEC_PrintCertificateAndTrust/**
(Assignee)

Updated

9 years ago
Priority: -- → P3
The stack added per comment 1 above is far too broad.
This is the same problem as bug 459237. 
Please remove the stack added per comment 1 above, and 
add a stack for bug 459237 which is similar to the existing 
stack for that bug.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 459237
You need to log in before you can comment on or make changes to this bug.