The current URL cannot be querried by another app

RESOLVED DUPLICATE of bug 516502

Status

()

Firefox
Shell Integration
P3
enhancement
RESOLVED DUPLICATE of bug 516502
17 years ago
3 years ago

People

(Reporter: Steve Cox, Assigned: Samir Gehani)

Tracking

(Blocks: 1 bug, {helpwanted})

Trunk
Future
All
Mac OS X
helpwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

556 bytes, text/applescript
Details
(Reporter)

Description

17 years ago
Mozilla does not respond to a request for the 'curl' property of the first 
'cwin'.  Older versions of Netscape Navigator respond by returning the 
current URL of the top-most window.

Comment 1

17 years ago
Adding RFE and Helpwanted keyword. Any takers?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: helpwanted
Summary: The current URL cannot be querried by another app → [RFE] The current URL cannot be querried by another app
Since Don has left, Vishy is taking his bugs in bulk, pending reassignment.
thanks,
	Vishy
Assignee: don → vishy

Comment 3

17 years ago
nav triage team:

Won't do this for beta1, marking nsbeta1-
OS: All

Comment 4

17 years ago
no, really, marking nsbeta1-
Keywords: nsbeta1-

Comment 5

17 years ago
Marking nsbeta1- bugs as future to get off the radar
Target Milestone: --- → Future

Comment 6

15 years ago
Reassigning to a real person.
Assignee: vishy → sgehani
QA Contact: sairuh → paw

Comment 7

15 years ago
[RFE] is deprecated in favor of severity: enhancement.  They have the same meaning.
Severity: normal → enhancement

Updated

15 years ago
Summary: [RFE] The current URL cannot be querried by another app → The current URL cannot be querried by another app

Comment 8

15 years ago
Does the following AppleScript do what you need?

tell application "Mozilla" to set SteveCox to (URL of front window)
return SteveCox

If so, this should be Resolved Fixed.
Product: Core → Mozilla Application Suite

Comment 9

8 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Status: NEW → UNCONFIRMED

Comment 10

8 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 11

8 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 12

8 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 13

8 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 14

8 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 15

8 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 16

8 years ago
I've tried several variations but can't find one that returns the URL or Title from Firefox.
Blocks: 125419
Depends on: 608049
No longer depends on: 608049

Comment 17

3 years ago
Can someone contribute a step by step instruction showing the problem in Seamonkey and showing that the problem does not exist in other Browsers? 15 Years UNCONFIRMED are a very long time ...

Comment 18

3 years ago
For what it's worth this script works

tell application "Safari" to set foo to (URL of current tab of front window)
return foo

whereas this one

tell application "Firefox" to set foo to (name of front window)
return foo

"46407 – The current URL cannot be querried by another app"

So in the intervening 15 years

1. tabbed browsing now exists
2. the idea that a window has a URL property seems to have gone away
3. the original program is not longer valid, now one has to write a program which is tab aware
4. Someone seems to have blocked access to the URL (which is bizarrely bound to the name) in Firefox, I would guess as a security measure

Where that leaves you I don't know. One could file a bug asking for Firefox to support tabs and uris similar to Firefox. But the original program report is very invalid at this point.

Comment 19

3 years ago
Created attachment 8563400 [details]
testcase applescript

The word "tab" is not defined in Firefox, so any script attempting to use a tab won't even compile. I had to comment that line out.

Safari successfully returns name, tab & document.
Chrome successfully returns title & tab.
Firefox only returns name.

Updated

3 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Component: UI Design → Shell Integration
OS: All → Mac OS X
Product: SeaMonkey → Firefox
Hardware: PowerPC → All
Resolution: --- → DUPLICATE
Duplicate of bug: 516502
You need to log in before you can comment on or make changes to this bug.