qa companion setup freezes on the system configuration step

RESOLVED FIXED

Status

Other Applications
QA Companion
--
major
RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: Yan Mosyagin, Assigned: cmtalbert)

Tracking

Trunk
x86
Windows Vista

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b2pre) Gecko/20081110 Minefield/3.1b2pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b2pre) Gecko/20081110 Minefield/3.1b2pre

I'm getting stuck on a "System Configuration" step when I try to complete all the steps of Mozilla QA Companion Setup guide. The only menus available are: Platform and Operating System.
Then there is a "Loading menu options..." string above them. And it seems to load them forever.

Reproducible: Always

Steps to Reproduce:
1. Open QA Companion
2. Follow the "QA Companion: Setup" wizard steps
3. Press "Next" until the "System Configuration" step.
Actual Results:  
The wizard gets stuck on the step "System Configuration". It seems that it can't load all the menus.

Expected Results:  
The wizard should load all the menus and show me them.

Version of Mozilla QA Companion add-on used: 0.1.17
(Reporter)

Updated

10 years ago
Version: unspecified → Trunk
(Assignee)

Comment 1

10 years ago
Created attachment 349519 [details] [diff] [review]
Patch to fix issue v1

Ok here is a patch that does a couple of things:
1. Fixes the reported issue
2. Creates functionality to throw an error dialog from anywhere in the code
3. Fixes a separate issue with the "existing account/create account" setup panel when it gets into an odd state because of the above error condition (it seems I've heard of this being reported, so I went ahead and fixed the oddity)
4. Cleans up code in common.js which was indented at two different levels (changed to two space indenting, sorry for the white space changes).  The only substantive changes to common.js were adding the showError and getString functions to the qaTools object.

The "hang" was actually caused by a javascript exception caused because the code that needed to be protected was outside the try/catch block, and the error being thrown didn't actually show an error dialog, thus appearing like a hang.
Assignee: nobody → ctalbert
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
(Assignee)

Updated

10 years ago
Blocks: 423508
(Assignee)

Updated

10 years ago
Attachment #349519 - Flags: review?(brian)

Comment 2

10 years ago
Comment on attachment 349519 [details] [diff] [review]
Patch to fix issue v1

Only gripe is that indentation/whitespcae changes should be put in a seaprate patch because it makes it harder to find the other changes.
Attachment #349519 - Flags: review?(brian) → review+
(Assignee)

Comment 3

10 years ago
(In reply to comment #2)
> (From update of attachment 349519 [details] [diff] [review])
> Only gripe is that indentation/whitespcae changes should be put in a seaprate
> patch because it makes it harder to find the other changes.

Good point.  I'll do that next time. Thanks for the review.
(Assignee)

Comment 4

10 years ago
Checked In:
Checking in chrome/content/common.js;
/cvsroot/mozilla/testing/extensions/community/chrome/content/common.js,v  <--  common.js
new revision: 1.8; previous revision: 1.7
done
Checking in chrome/content/litmus.js;
/cvsroot/mozilla/testing/extensions/community/chrome/content/litmus.js,v  <--  litmus.js
new revision: 1.20; previous revision: 1.19
done
Checking in chrome/content/settings.js;
/cvsroot/mozilla/testing/extensions/community/chrome/content/settings.js,v  <--  settings.js
new revision: 1.9; previous revision: 1.8
done
Checking in chrome/content/setup.xul;
/cvsroot/mozilla/testing/extensions/community/chrome/content/setup.xul,v  <--  setup.xul
new revision: 1.10; previous revision: 1.9
done
Checking in chrome/locale/en-US/qa.properties;
/cvsroot/mozilla/testing/extensions/community/chrome/locale/en-US/qa.properties,v  <--  qa.properties
new revision: 1.7; previous revision: 1.6
done
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.