"momentary not available" UI is confusing, not actionable

NEW
Unassigned

Status

10 years ago
8 years ago

People

(Reporter: dmose, Unassigned)

Tracking

Bug Flags:
tb-integration +

Details

(Whiteboard: [needs activity manager])

(Reporter)

Description

10 years ago
Right now, in certain situations after (certain?) errors, an exclamation mark will appear next to the calendar, and mousing over that will display the text "The calendar Foo is momentarily not available".  Given that the events from that calendar are still being displayed in view, that message seems confusing.  Additionally, it's not clear what consequences of being in that state are.  Clicking the icon in question does nothing, and it's not clear in what way (if any) the user would want to change their behavior based on the presence of this icon.

CCing the caldav provider QA contact, because I see this using a Zimbra CalDAV server, and it's perhaps partly related to the specific semantics of when the CalDAV provider is throwing a particular error.
Flags: tb-integration+
Whiteboard: [needs activity manager]

Comment 1

9 years ago
This same error occurred using Yahoo Calendars.  It was working beautifully for about 3 weeks and then suddenly the message "The calendar Foo is momentarily not available" appeared on my desktop and laptop calendars ( in Lightning). Only some of the events were showing, more than half are missing.  Rebooting did not solve the issue.

The Yahoo CALDAV still works beautifully in the iPhone, just not in Lightning.  Yahoo support referred me back to Mozilla.
Yahoo CalDAV works fine for me in the latest nightlies. Usually it should be sufficient to just reload remote calendars, and if thats not enough then just create an event. This is of course just a workaround.

Comment 3

9 years ago
Thanks for the reply Philipp.  I tried refreshing and adding a new event, as well as deleting the existing caledar and recreating it from scratch.  I am still getting the error with only some of my events listed.  I am at a loss as to what to try next.  Sure do miss my Lightning alerts though!
OS: Mac OS X → All
Hardware: x86 → All
You need to log in before you can comment on or make changes to this bug.