xml template : elements between the <action> tag and the uri="?" are merged

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
10 years ago
8 years ago

People

(Reporter: jmbastide, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2010-11-01])

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.9.0.3) Gecko/2008092417 Firefox/3.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.9.0.3) Gecko/2008092417 Firefox/3.0.3

try rendering the following xul :

Note the labels and groupboxes between the <action> and the uri="?". Elements with the same tag are merged...

<?xml version="1.0"?>

<?xml-stylesheet href="chrome://global/skin/" type="text/css"?> 

<window xmlns="http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul">

<people id="famouspeople" xmlns="">
  <person name="Napoleon Bonaparte" gender="male"/>
  <person name="Cleopatra" gender="female"/>
  <person name="Julius Caesar" gender="male"/>
  <person name="Ferdinand Magellan" gender="male"/>
  <person name="Laura Secord" gender="female"/>
</people>

<vbox datasources="#famouspeople" ref="*" querytype="xml">
  <template>
    <query expr="person"/>
    <action>
      <label value="first title line"/>
      <label value="second title line"/>
      <text value="third title line"/>
      <groupbox>
          <label value="groupbox1"/>
      </groupbox>
      <groupbox>
          <label value="groupbox2"/>
      </groupbox>
      <groupbox>
          <text value="groupbox3"/>
      </groupbox>
      <hbox uri="?" align="center">
        <button label="?name"/>
        <label value="?gender"/>
      </hbox>
    </action>
  </template>
</vbox>
</window>

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Actual Results:  
title2 is merged with title1
groupbox2 is merged with groupbox1 and labels inside are also merged
groupbox3 is merged with groupbox1

Expected Results:  
No merge at all
This is a mass search for bugs which are in the Firefox General component, are
UNCO, have not been changed for 500 days and have an unspecified version. 

Reporter, can you please update to Firefox 3.6.10 or later, create a fresh profile, http://support.mozilla.com/en-US/kb/managing+profiles, and test again. If you still see the issue, please update this bug. If the issue is gone, please set the status to RESOLVED > WORKSFORME.
Whiteboard: [CLOSEME 2010-11-01]
(Reporter)

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.