Closed Bug 464353 Opened 13 years ago Closed 13 years ago

[10.6] Upside down checkmarks

Categories

(Core :: Widget: Cocoa, defect)

All
macOS
defect
Not set
normal

Tracking

()

VERIFIED FIXED
mozilla1.9.2a1

People

(Reporter: marcia, Assigned: smichaud)

References

Details

(Keywords: verified1.9.1, Whiteboard: [fixed by bug 450800])

Attachments

(2 files, 1 obsolete file)

Seen while running Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.1b2pre) Gecko/20081111 Minefield/3.1b2pre. This bug is being filed to track an Apple bug.

STR:

1. File | Import
2. Import from Safari
3. Observe attached screenshot
This needs to be investigated early in case we need Apple to fix a bug.
Assignee: joshmoz → smichaud
This doesn't happen in Firefox 3.0.3, and I've found a regression
range:

firefox-10-13-02-mozilla-central
firefox-10-14-02-mozilla-central

http://hg.mozilla.org/mozilla-central/pushloghtml?startdate=2008-10-13+00%3A00%3A00&enddate=2008-10-14+05%3A31%3A00

Markus' patch for bug 394892 is in this range, so I think it's very
likely to have triggered this bug ... which (on the face of it) seems
likely to be an Apple bug.

Markus, do you have access to a copy of SnowLeopard?  It's now
available on ADC (to those with at least a Select membership).  It
should also be possible to get a copy from Josh.

In any case I'll keep digging, since (I think) it shouldn't be too
hard to find the trigger.
Argh. I think this happens because Apple fixed a bug...
IIRC we explicitly set up a flip transform because otherwise checkboxes would be upside down on 10.5.
I don't have a copy of 10.6 yet.
Attached patch Possible fix (obsolete) — Splinter Review
Here's a patch that seems to fix this problem.

That it works seems to confirm what Markus says in comment #4 -- Apple
appears to have fixed a bug in SnowLeopard that we previously had to
work around (in Leopard).

But there are *lots* of other places where we use (vertical) flip
transforms in nsNativeThemeCocoa.mm, and where they still seem to be
needed.  Though it's a bit hard to tell -- buttons and scrollbars and
the like are (aside from the text) usually vertically symmetrical.

Markus:  Are the other places we use flip transforms in
nsNativeThemeCocoa.mm also (in effect) workarounds for Apple bugs?  If
so, should we try to get one or more of them fixed in SnowLeopard?
That is, is it worth our while to isolate them and report them to
Apple as bugs?  The fewer distinct bugs there are (and the fewer bug
reports we'd have to open with Apple), the more "economical" it would
be to report them to (and, presumably, the more likely Apple'd be
willing to fix them).
Attachment #347842 - Flags: review?(mstange)
Here's a tryserver build made with my patch from comment #5:

https://build.mozilla.org/tryserver-builds/2008-11-12_13:14-smichaud@pobox.com-bugzilla464353/smichaud@pobox.com-bugzilla464353-firefox-try-mac.dmg

Marcia, please bang away on it and let us know what you think.
Steven, before I review your patch, I'll write a small testing app that tests all kinds of ways of NSCell drawing. We really need to know what triggers drawing problems on which OS versions, especially since I'll change a lot of the drawing stuff in bug 450800.
Sounds good to me, Markus.
The build in Comment 6 resolves the issues I was seeing both in Import and Preferences with the upside down checkmarks. The world has now been righted...
Depends on: 465069
My patch in bug 450800 also fixes this bug.
Comment on attachment 347842 [details] [diff] [review]
Possible fix

(In reply to comment #10)

On the strength of this comment, and of the continuing work in bug
450800 and bug 465069, I'm marking my patch obsolete.
Attachment #347842 - Attachment is obsolete: true
Attachment #347842 - Flags: review?(mstange)
Should be fixed by bug 450800.
Status: NEW → RESOLVED
Closed: 13 years ago
Hardware: PC → All
Resolution: --- → FIXED
Whiteboard: [fixed by bug 450800]
Target Milestone: --- → mozilla1.9.2a1
Marcia, could you please check if everything is ok on Snow Leopard? Thanks.
Keywords: fixed1.9.1
I can check, but will do so when I get a new seed which hopefully should be soon.
verified fixed on the 1.9.1 branch using Mac OS X 10.6 (10A261) and Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.1b3pre) Gecko/20090208 Shiretoko/3.1b3pre.
Verified fixed on trunk with Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2a1pre) Gecko/20090209 Minefield/3.2a1pre
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.