Closed Bug 464377 Opened 11 years ago Closed 11 years ago

<video> fires load events twice

Categories

(Core :: Audio/Video, defect, P2)

x86
macOS
defect

Tracking

()

RESOLVED DUPLICATE of bug 464376

People

(Reporter: Dolske, Assigned: cajbir)

References

Details

(Whiteboard: [depends on 464376])

Attachments

(1 file)

No description provided.
(*sigh* Pressed enter at the wrong time and submitted too fast.)

Bug 464371 describes a problem with load events coming from images in the XBL binding.

But I'm also seeing double loads from the video itself... My load listener get called twice with event.originalTarget.localName set to "VIDEO" (in addition to the calls from the XBL issue).

Maybe one is due to the HTTP byte-range request to calculate the duration (bug 449307)? When loading http://www.double.co.nz/video_test/test3.html, I get one VIDEO load event quickly, and the second after a noticeable delay.
Yeah, I discovered this writing a test for bug 464376 and am trying to track it down. I actually get three. Two in quick succession, which are not progress events, followed by a third which is.
It seems that there were two sources of spurious load events: bug 464371, and a different problem with ResourceLoaded firing multiple times. The latter is fixed in bug 464376. So this bug should be fixed when 464376 is checked in.
Blocks: 464376
No longer blocks: 464376
Depends on: 464376
Priority: -- → P2
Whiteboard: [depends on 464376]
Assignee: nobody → chris.double
Bug 464376 has been checked in now. Does this fix this bug?
I think this is fixed.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Yeah, seems to be fixed. Modifying my test to use the |load| event no longer fails due to multiple events firing.
Duping, since 464376 fixed this, and this bug shows up on the "fixed on trunk but not branch" list.
Resolution: FIXED → DUPLICATE
Duplicate of bug: 464376
You need to log in before you can comment on or make changes to this bug.