When checking mail, if I cancel "Enter password" dialog, Thunderbird prompts me again 47 times

RESOLVED DUPLICATE of bug 423354

Status

MailNews Core
Networking: IMAP
RESOLVED DUPLICATE of bug 423354
10 years ago
10 years ago

People

(Reporter: dholbert, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Created attachment 347693 [details]
screenshot of the password dialog (which I get 47 consecutive copies of)

STR:
 1. Set up Thunderbird "Shredder" to connect to a Gmail account via IMAP.  Do *not* store your password.
 2. Click the "Get Mail" button on the toolbar.
 3. When you're prompted for your Gmail Password, press "Esc"

ACTUAL RESULTS:
  Shredder popped up ***47*** consecutive "enter password" dialogs before it gave up.  All of these prompted for the same password -- the password on my Gmail account.

EXPECTED RESULTS:
  After I cancel the first password dialog, it should abort the mail-checking operation and stop bugging me.

Build ID: version 3.0a2 (2008072418)
OS: Ubuntu Linux 8.10
Component: General → Networking: IMAP
Product: Thunderbird → Core
QA Contact: general → networking.imap
NOTE #1: In the real world, I tend to run into this bug from time to time when Gmail's auth servers are broken (happens every few weeks), and they reject my saved (correct) password, which makes Thunderbird re-prompt me.  When that happens, I have to click "Cancel" on this same long stream of Password dialogs in order to get back to Thunderbird again.

NOTE #2: I have about 20 folders in Gmail -- I'm guessing that the number of prompts has to do with the number of folders that I have.  (However, none of these folders have "Check this folder for new messages" enabled, so I don't know why Thunderbird would be checking them...)

Comment 2

10 years ago
This sounds like a duplicate of bug 423354.

(47 times, maybe you set the hidden pref to check all imap folders for new...)

Please try a recent build, 3.0alpha2 is ancient by now.
(In reply to comment #2)
> (47 times, maybe you set the hidden pref to check all imap folders for new...)

Ah-ha, you are correct! I have mail.check_all_imap_folders_for_new turned on.  I'd forgotten about that pref.

> Please try a recent build, 3.0alpha2 is ancient by now.

I just tried latest-trunk (Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b2pre) Gecko/20081111 Shredder/3.0b1pre) and it appears to be fixed!!! Hooray! :)
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME

Comment 4

10 years ago
Duping...
Resolution: WORKSFORME → DUPLICATE
Duplicate of bug: 423354

Comment 5

10 years ago
Could this be merged into the 2.x tree and sent out in the next update?  Thunderbird 2.x is very difficult to use on multiple computers for long periods of time if an account is connecting to a gmail imap server.  The disconnects are likely a gmail problem, but this fix should make those disconnects and the re-authentication process invisible to the user.
(Assignee)

Updated

10 years ago
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.