Closed Bug 464444 Opened 11 years ago Closed 11 years ago

No event notification eMail when organizer deletes the last attendee

Categories

(Calendar :: E-mail based Scheduling (iTIP/iMIP), defect)

defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: andreas.treumann, Assigned: dbo)

Details

Attachments

(1 file)

STEPS TO REPRODUCE:
===================

- create an event with two attendees
- delete one from the list and save this
- event notification dialog pops up
- delete the last attendee and save this

RESULT:
=======

- not event notification dialog pops up

EXPECTED RESULT:
================

- the organizer should get the event notification dialog


REPRODUCIBLE:
=============

- always
Attached patch fixSplinter Review
Assignee: nobody → daniel.boelzle
Attachment #347981 - Flags: review?(philipp)
Status: NEW → ASSIGNED
Comment on attachment 347981 [details] [diff] [review]
fix


shouldn't you be deleting the property from the item if there are no attendees?

r=philipp with question answered
Attachment #347981 - Flags: review?(philipp) → review+
Comment on attachment 347981 [details] [diff] [review]
fix


shouldn't you be deleting the property from the item if there are no attendees?

r=philipp with question answered
(In reply to comment #3)
> shouldn't you be deleting the property from the item if there are no attendees?
No, because the property is evaluated later on by the iTIP checking code (whether to send out the CANCEL messages or not).

Pushed to comm-central <http://hg.mozilla.org/comm-central/rev/cc0f07c15241>

-> FIXED
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.0
Checked with lightning build 20081119 -> VERIFIED.
Status: RESOLVED → VERIFIED
Target Milestone: 1.0 → 1.0b1
You need to log in before you can comment on or make changes to this bug.