Closed Bug 464489 Opened 12 years ago Closed 2 years ago

favicon for google reader bookmark on bookmark toolbar switches between rel="SHORTCUT ICON" and rel="icon"

Categories

(Firefox :: Bookmarks & History, defect)

15 Branch
x86
Windows Vista
defect
Not set

Tracking

()

RESOLVED INCOMPLETE

People

(Reporter: james, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b2pre) Gecko/20081112 Minefield/3.1b2pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b2pre) Gecko/20081112 Minefield/3.1b2pre

the bookmarks toolbar icon for google reader keeps switching between 2 different icons

Reproducible: Always

Steps to Reproduce:
1. go to google reader and login, view 'all items'
2. bookmark the page onto the bookmark toolbar
3. close the tab and re-open the bookmark multiple time
Actual Results:  
the bookmark icon switches between the icon linked by <link href="/reader/ui/favicon.ico" rel="SHORTCUT ICON"> and the icon link by <link rel="icon" href="/reader/ui/573007822-app-icon-32.png" sizes="32x32"> fairly randomly.

The icon on the tab is always the favicon


Expected Results:  
the bookmark icon to display the right icon continuously 

Happens on the lastest nightlys with chrome jit on or off.

Have tested this in a new profile
forgot to add, the source for the page is a little suspect, this is part of the head:

<link href="/reader/ui/favicon.ico" rel="SHORTCUT ICON">
<meta name="application-name" content="Google Reader">
<meta name="description" content="Get all your news and blogs in one place with Google Reader">
<meta name="application-url" content="/reader/view/">
<link rel="icon" href="/reader/ui/573007822-app-icon-32.png" sizes="32x32">
<link rel="icon" href="/reader/ui/4283503602-app-icon-64.png" sizes="64x64">
<link href="/reader/ui/favicon.ico" rel="SHORTCUT ICON">


notice the multiple links to icons.....
The repetition of the favicon was an attempt to work around this bug, it seemed to help at the time (I'm a Google Reader Engineer).
Still happening with 3.7 nightlies.
Reporter, are you still seeing this issue with Firefox 4.0.1 or later in safe mode or a fresh profile? If not, please close. These links can help you in your testing.
http://support.mozilla.com/kb/Safe+Mode
http://support.mozilla.com/kb/Managing+profiles
Whiteboard: [CLOSEME 2011-05-30]
Version: unspecified → 3.5 Branch
No reply, INCOMPLETE. Please retest with Firefox 4 or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). Also, ensure you have the most up to date graphics drivers, operating system updates, and plugin versions (flash, java, etc). If you continue to see this issue with the newest Firefox and a new profile, then please comment on this bug.
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → INCOMPLETE
Hi, several users are experiencing a problem similar (or exactly the same) as this one on the news aggregater site reddit.com. They reported an issue here: http://www.reddit.com/r/firefox/comments/y6sh8/firefox_favicon_problem_on_reddit/

Is there any chance to get this bug reopened and fixed?
My guess is that this is related to caching, but I haven't looked enough to be sure. 

Both Google Reader and Reddit specify expiration times far enough into the future that Firefox is undoubtedly grabbing new copies before expiration.  

Assuming that involves throwing away the icon, and the "fallback" (ie, another entry on the page) is already grabbed/not expired, it's switching over to what it already has.

As I recall (don't currently have any visible bookmarks), the right icon would get used after reloading the offending page/domain, which means the next time around it would have the updated favicon and would use that first entry.

I'll try to find a few cycles to dig around and confirm this hypothesis.
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: INCOMPLETE → ---
Whiteboard: [CLOSEME 2011-05-30]
Here's what's happening:

setIcon to http://www.redditstatic.com/icon.png
setIcon@chrome://browser/content/tabbrowser.xml:684
DOMLinkHandler.onLinkAdded@chrome://browser/content/browser.js:9514
DOMLinkHandler.handleEvent@chrome://browser/content/browser.js:9419
tab now has http://www.redditstatic.com/icon.png
setIcon to http://www.redditstatic.com/favicon.ico
setIcon@chrome://browser/content/tabbrowser.xml:684
DOMLinkHandler.onLinkAdded@chrome://browser/content/browser.js:9514
DOMLinkHandler.handleEvent@chrome://browser/content/browser.js:9419
tab now has http://www.redditstatic.com/favicon.ico
ASSOCIATES http://www.redditstatic.com/favicon.ico with http://www.reddit.com/
ASSOCIATES http://www.redditstatic.com/icon.png with http://www.reddit.com/

The ASSOCIATES lines are from asynchronous threads of AsyncFaviconHelpers.cpp (~720, AsyncAssociateIconToPage::Run, which gets called after retrieving the icon or directly (if cached)).  They can happen out of order on the occasions that the icons are actually fetched, because the icon.png is bigger/takes longer.  The next reload of the page, they happen in the "correct" order, owing to no appreciable latency.
A lot has changed in favicons in the last 6 years, especially over the last year or so. If this is still happening, please file a new bug with steps to reproduce.
Status: REOPENED → RESOLVED
Closed: 9 years ago2 years ago
Component: General → Bookmarks & History
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.