Give processed removed-files some IFLAGS lovin'

RESOLVED FIXED in mozilla1.9.1b3

Status

RESOLVED FIXED
10 years ago
15 days ago

People

(Reporter: philor, Assigned: philor)

Tracking

({fixed1.9.1})

Trunk
mozilla1.9.1b3
fixed1.9.1

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

10 years ago
There are several things that keep me up nights, but one of the worst is the fear that someone will execute removed-files, since we let it wind up with 755 perms. Slapping it with the 644 from IFLAGS1 will let me get some sleep, or at least give me more time to worry about whether the tag is still attached to my mattress.
(Assignee)

Comment 1

10 years ago
Oh, I bet my failure to attach the patch explains why such a simple thing has sat without review for a week, doesn't it?
Better than blaming it on me!
(Assignee)

Comment 3

10 years ago
Created attachment 348844 [details] [diff] [review]
Fix

Okay, *now* it's your fault.

Tick.

Tick.
Attachment #348844 - Flags: review?(ted.mielczarek)
(Assignee)

Updated

10 years ago
Duplicate of this bug: 325899
Attachment #348844 - Flags: review?(ted.mielczarek) → review+
Comment on attachment 348844 [details] [diff] [review]
Fix

I'm just going to give you blanket r=me to change $(IFLAGS) anywhere you need to to fix permissions things like this.
(Assignee)

Comment 6

10 years ago
http://hg.mozilla.org/mozilla-central/rev/b82a593f9b52
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
(Assignee)

Updated

10 years ago
Attachment #348844 - Flags: approval1.9.1?

Comment 7

10 years ago
It's still executable:
-rwxr-xr-x  1 root     root        3804 11. Dez 13.26 removed-files

Mozilla/5.0 (X11; U; Linux i686 (x86_64); de; rv:1.9.1b3pre) Gecko/20081211 Shredder/3.0b2pre
(Assignee)

Comment 8

10 years ago
(In reply to comment #7)
> rv:1.9.1b3pre

That sounds a lot like 1.9.1 to me. I see an approval1.9.1? flag on the bug, but not any fixed1.9.1 keyword.
Comment on attachment 348844 [details] [diff] [review]
Fix

a191=beltzner
Attachment #348844 - Flags: approval1.9.1? → approval1.9.1+
(Assignee)

Comment 10

10 years ago
https://hg.mozilla.org/releases/mozilla-1.9.1/rev/96c8028b34b4
Keywords: fixed1.9.1
Target Milestone: --- → mozilla1.9.1b3

Updated

15 days ago
Product: Toolkit → Toolkit Graveyard
You need to log in before you can comment on or make changes to this bug.