All users were logged out of Bugzilla on October 13th, 2018

Ability to have an "Other..." option for drop-down custom fields

UNCONFIRMED
Unassigned

Status

()

--
enhancement
UNCONFIRMED
10 years ago
10 years ago

People

(Reporter: mkanat, Unassigned)

Tracking

Details

(Reporter)

Description

10 years ago
NASA has asked me to implement the following feature:

There should be a boolean option for a <select> custom field to have an "Other..." option. If this option is selected, there would be an empty text box that would appear next to the drop-down, where any free text could be entered, up to 64 characters.

Currently, I'm actually *against* implementing this feature in upstream Bugzilla, because we're going to be moving all the values in the bugs table to be foreign keys instead of text values. It's very easy to implement "other" when all you have to do is put some text in the bugs table--it's obnoxious when you have to have a whole separate table (which would have to be accessed in search for *every* search) or another column just for the "other" value.
(Reporter)

Comment 1

10 years ago
Also, nobody's ever asked for this feature--as evidenced by the fact that I had to file this bug myself.
(Reporter)

Comment 2

10 years ago
Just to clarify, when I agreed to do this for NASA, I thought it was a good idea, because we weren't looking at moving to foreign keys any time soon, and so the added complexity would have been minimal. It's just that things changed, and now I'd have to see enough user demand to justify the added complexity.

NASA's intention here was to contribute back to the community various features that they had created internally--no desire to force us to implement something we don't want. (And in fact, so far their funding paid for all the new custom field types and features in 3.2 and 3.4.)

Comment 3

10 years ago
IIUC, you are filing a bug for something you don't want?! Did you ever try to file a bug as RESOLVED WONTFIX? :-D
(Reporter)

Comment 4

10 years ago
Hahahaha. I'm filing a bug so that we can discuss whether we want to do this now, want to do it at some point in the future, or never want to do it. Also, maybe some users will come along and say, "Hey yeah, I did want that."

Comment 5

10 years ago
This can be useful, we have this already with our guided form, but implemented as: once a certain value is selected in the dropdown box, another free text field becomes mandatory.

So, as I see it, it could be useful upstream as a variant of bug 308253.

maybe "mandatory" should be read as "enforcing regular expression" but probably there is no direct need for that.

I think this is less complex, because 
>you have to have a whole separate table (which would have to be accessed in
>search for *every* search) or another column just for the "other" value.
isn't true anymore . But ok, maybe that's a specific requirement for NASA.

Comment 6

10 years ago
> I think this is less complex, because 
> >you have to have a whole separate table (which would have to be accessed in
> >search for *every* search) or another column just for the "other" value.
> isn't true anymore . But ok, maybe that's a specific requirement for NASA.

I mean: at least bugzilla don't have to search that extra field every time - I see that as a responsability for the user.
(Reporter)

Comment 7

10 years ago
(In reply to comment #6)
> I mean: at least bugzilla don't have to search that extra field every time - I
> see that as a responsability for the user.

  That would just be confusing to the user.
You need to log in before you can comment on or make changes to this bug.