Last Comment Bug 464660 - Spelling Checker (for TB, SM, and possibly FX?) should be able to change language in a msg
: Spelling Checker (for TB, SM, and possibly FX?) should be able to change lang...
Status: RESOLVED DUPLICATE of bug 69687
:
Product: Core
Classification: Components
Component: Spelling checker (show other bugs)
: 1.9.0 Branch
: All All
: -- enhancement (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-13 04:15 PST by Onno Ekker [:nONoNonO UTC+1]
Modified: 2009-06-20 01:19 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
A mail with <span lang=".."> (766 bytes, message/rfc822)
2008-11-13 04:15 PST, Onno Ekker [:nONoNonO UTC+1]
no flags Details

Description Onno Ekker [:nONoNonO UTC+1] 2008-11-13 04:15:29 PST
Created attachment 347949 [details]
A mail with <span lang="..">

When typing a message, I sometimes switch language, for instance when I type in my own language (dutch) and quote some other text in english.
Now, all those English words are not recognized by the Spelling Checker, until I switch language to English, but then the Dutch words aren't recognized.

It would be better to be able to specify the language in the message, just as it is possible in Word of OpenOffice. You could maybe use DOM for that, or HTML <span lang="nl">..</span> elements and make Spelling Checker recognize them and switch dictionary.

This would be very useful for Thunderbird (and Seamonkey), but could also be useful for Firefox in text fields, when editing some wiki or other page.

The e-mail GUI should have an option to change the language in a message, or for some selected text and the spelling checker should change dictionary when it sees such a marker.
Comment 1 Matt Caywood 2009-06-20 01:19:21 PDT

*** This bug has been marked as a duplicate of bug 69687 ***

Note You need to log in before you can comment on or make changes to this bug.