3pane context menus: Sender selected should match spec

RESOLVED WORKSFORME

Status

SeaMonkey
MailNews: Message Display
P3
normal
RESOLVED WORKSFORME
18 years ago
13 years ago

People

(Reporter: Ninoschka Baca, Assigned: timeless)

Tracking

(Blocks: 1 bug, {polish, verifyme})

Trunk
polish, verifyme

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Build 2000-07-25-09M17: NT4
Haven't checked Mac or Linux yet.

Overview: In the Message pane's Envelope area, right click onto the Sender's 
email address and a context menu appears. The spec states that the following 
should appear:

New Message to <name>
Reply to <name>
--------------------------
Add <name> to Address Book
--------------------------
Send <name> an Instant Message
Add <name> to Buddy List


Currently the context menu shows two items which are labeled incorrectly and are 
in the wrong order:

- Add Address to Address Book
- Send Mail To
(Reporter)

Updated

18 years ago
Keywords: nsbeta3, polish
QA Contact: lchiang → nbaca
(Reporter)

Comment 1

18 years ago
The same context menu items appear when the recipient (To and Cc) area is 
selected. To track the recipient issue, can we use this bug?
(Reporter)

Comment 2

18 years ago
The same context menu items appear for the sender in a News message. Can we use 
this bug since the context menu items should be the same or log another bug?

Comment 3

18 years ago
the same bug is fine.
(Assignee)

Comment 4

18 years ago
Welcome to bugzilla please create a Bugscape bug for the last 3 items, thank 
you.
Assignee: putterman → timeless
OS: Windows NT → All

Comment 5

18 years ago
mscott, in a meeting a while back we agreed that right or left clicking on a 
Sender (From) or Recipient (To or Cc) would bring up the same context menu. I 
can't find my notes from that meeting. Do you rememeber the menu items we agreed 
on?  I think it was:

Send Message to 
something here??
----------------------------------
Add Sender to Address Book
Add all Recipients to Address Book
----------------
Send an Instant Message
Add to Buddy List

Comment 6

18 years ago
I just confirmed with mscott, the correct content menu is:

&Add to Address Book
&Send Mail to
--------------
Add to &Buddy List
Send &Instant Message

With IM stuff removed for Mozilla.
And IM stuff removed if user not signed onto IM.
(Assignee)

Comment 7

18 years ago
Reminder to self. Is this fixed since the spec has changed?
Status: NEW → ASSIGNED
Keywords: verifyme

Comment 8

18 years ago
Removing the nsbeta3 nomination.  These will be condensed into a smaller number 
of bugs and then renominated.  
Keywords: nsbeta3
(Reporter)

Updated

17 years ago
QA Contact: nbaca → olgam

Updated

16 years ago
Blocks: 158011

Comment 9

15 years ago
Is this bug still valid? Using the 20030912 nightly on Win2k the context menu
looks vastly different. Looks to me like the spec changed and this bug fell into
a black hole. WORKSFORME/INVALID?

Comment 10

14 years ago
This is now working as expected. 
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.