Upgrade to SQLite 3.6.6.2

VERIFIED FIXED in mozilla1.9.1b3

Status

()

Toolkit
Storage
P2
normal
VERIFIED FIXED
10 years ago
9 years ago

People

(Reporter: sdwilsh, Assigned: sdwilsh)

Tracking

({verified1.9.1})

Trunk
mozilla1.9.1b3
verified1.9.1
Points:
---
Dependency tree / graph
Bug Flags:
blocking1.9.1 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 2 obsolete attachments)

(Assignee)

Description

10 years ago
Scheduled for release on December 1, 2008.

We cannot take 3.6.5 because our automated test suite caught a bug in it (http://www.sqlite.org/cvstrac/tktview?tn=3497).


Requesting blocking because this blocks bug 462173, and we need a newer SQLite to fix it (anything newer than 3.6.5 will do for that bug).
Flags: blocking1.9.1?
I discussed this with sdwilsh on IRC, and decided that this in itself doesn't block the Firefox 3.1 release since it's hard to block on external dependencies. That said, fixing bug 462173 and allowing async queries will allow for a more responsive UI, and Shawn's obviously been very careful about testing versions of SQLite to ensure they don't break us, so I think that if it comes up for approval, we should seriously consider it.
Flags: blocking1.9.1? → blocking1.9.1-
(Assignee)

Comment 2

10 years ago
Created attachment 349089 [details] [diff] [review]
v1.0

It came out sooner. :)

This also needs the changes to the sqlite files, and that patch can be found here:
http://hg.mozilla.org/users/sdwilsh_shawnwilsher.com/storage-async/file/d0bc383c3001/sqlite.upgrade
Attachment #349089 - Flags: review?(bugmail)
(Assignee)

Updated

10 years ago
Whiteboard: [has patch][needs review asuth]
(Assignee)

Comment 3

10 years ago
try server shows no regressions
Comment on attachment 349089 [details] [diff] [review]
v1.0

I have also verified that the upgrade patch produces results identical to the contents of the sqlite 3.6.6 amalgamation release (though omitting sqlite3ext.h).
Attachment #349089 - Flags: review?(bugmail) → review+
(Assignee)

Comment 5

10 years ago
There is a reported corruption issue with 3.6.4 - 3.6.6.  It'll be fixed in 3.6.7, which we should take, and we should block the release of 1.9.1 on.
Flags: blocking1.9.1- → blocking1.9.1?
Summary: Upgrade to SQLite 3.6.6 → Upgrade to SQLite 3.6.7
Whiteboard: [has patch][needs review asuth] → [needs new patch]
(Assignee)

Comment 6

10 years ago
3.6.6.1 came out sooner because they didn't like having a release out there with the corruption bug present.
Summary: Upgrade to SQLite 3.6.7 → Upgrade to SQLite 3.6.6.1
(Assignee)

Comment 7

10 years ago
Created attachment 349999 [details] [diff] [review]
v1.1

Updated our changes for 3.6.6.1.

This also takes http://hg.mozilla.org/users/sdwilsh_shawnwilsher.com/storage-async/file/6554fd2c6e40/sqlite.upgrade
Attachment #349089 - Attachment is obsolete: true
Attachment #349999 - Flags: review?(bugmail)
(Assignee)

Updated

10 years ago
Whiteboard: [needs new patch] → [has patch][needs review asuth]
(Assignee)

Updated

10 years ago
Blocks: 464095
Attachment #349999 - Flags: review?(bugmail) → review+
Whiteboard: [has patch][needs review asuth] → [has patch][has review]
(Assignee)

Updated

10 years ago
Attachment #349999 - Flags: approval1.9.1?
Stuart: sdwilsh says you guys want this for mobile, too?

Comment 9

10 years ago
um, yeah, this fixes windows mobile.
(Assignee)

Updated

10 years ago
Attachment #349999 - Attachment is obsolete: true
Attachment #349999 - Flags: approval1.9.1?
(Assignee)

Comment 10

10 years ago
yay...

From sqlite-users mailing list:
SQLite version 3.6.6.2 is now available for download on the SQLite
website

    http://www.sqlite.org/download.html

Version 3.6.6.2 fixes a bug that could potentially lead to database
corruption.  The bug was introduced in SQLite version 3.6.6.  The bug
was discovered by an assert() failure during stress testing and has
not been seen in the wild.

Database corruption resulting from this bug is still only a
theoretical possibility.  Despite focused efforts, we have so far been
unable to generate a test case that actually causes database
corruption.  Nevertheless, the nature of the bug suggests that such a
test should be possible, even if it is difficult to devise.  The fact
we have have been unable in creating a test case suggests the bug is
unlikely to be causing problems in the real world.  Even so, we are
issuing this branch release out of an abundance of caution and
recommending that all users of SQLite version 3.6.6 and 3.6.6.1
upgrade to version 3.6.6.2.


D. Richard Hipp
drh@hwaci.com
Summary: Upgrade to SQLite 3.6.6.1 → Upgrade to SQLite 3.6.6.2
Whiteboard: [has patch][has review] → [needs new patch]
(Assignee)

Comment 11

10 years ago
Created attachment 350379 [details] [diff] [review]
v1.3

Same as before, with a version bump
Attachment #350379 - Flags: approval1.9.1?
(Assignee)

Updated

10 years ago
Whiteboard: [needs new patch] → [has patch][has review][needs approval]
Comment on attachment 350379 [details] [diff] [review]
v1.3

a191=beltzner
Attachment #350379 - Flags: approval1.9.1? → approval1.9.1+
Flags: blocking1.9.1? → blocking1.9.1+
Priority: -- → P2
(Assignee)

Updated

10 years ago
Whiteboard: [has patch][has review][needs approval] → [has patch][has review][can land]
(Assignee)

Comment 13

10 years ago
http://hg.mozilla.org/mozilla-central/rev/10099d01717a
http://hg.mozilla.org/mozilla-central/rev/97a05adac5ba

I'll land this on branch later today (once we've had a few runs of perf data)
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Whiteboard: [has patch][has review][can land]
Target Milestone: mozilla1.9.1 → mozilla1.9.1b3
1.9.1 and trunk are up to 3.6.10.  marking bug verified.

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b4pre)
Gecko/20090407 Shiretoko/3.5b4pre

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2a1pre)
Gecko/20090407 Minefield/3.6a1pre
Status: RESOLVED → VERIFIED
Keywords: fixed1.9.1 → verified1.9.1
You need to log in before you can comment on or make changes to this bug.