Closed Bug 464863 Opened 12 years ago Closed 12 years ago

"ASSERTION: Should be in an update while creating frames" with XBL

Categories

(Core :: XBL, defect)

x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: jruderman, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: assertion, regression, testcase)

Attachments

(2 files)

563 bytes, application/xhtml+xml
Details
7.96 KB, text/plain
Details
Attached file testcase
Loading the testcase triggers:

###!!! ASSERTION: Should be in an update while creating frames: 'mUpdateCount != 0', file /Users/jruderman/central/layout/base/nsCSSFrameConstructor.cpp, line 8371

I also managed to get the same for "destroying", but not with the same testcase.

This is a regression from within the last day or so.  I'm hitting it a lot.
Attached file stack trace
That's really odd, since we're going through a DOM API....
Bug 470167 also triggers this assertion, but uses stylesheets instead of XBL.
This WFM in a current trunk build...
WFM, loading both from Bugzilla and locally.  I'll add a crashtest.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → WORKSFORME
Added crashtest:
http://hg.mozilla.org/mozilla-central/rev/63120a5301f2
Flags: in-testsuite+
You need to log in before you can comment on or make changes to this bug.