Closed Bug 464913 Opened 11 years ago Closed 11 years ago

KB articles have no screenshots

Categories

(mozilla.org Graveyard :: Server Operations, task, critical)

task
Not set
critical

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: cilias, Assigned: justdave)

References

()

Details

(Keywords: regression)

All articles that supposed to contain images (via image uploader) are not displaying any them.
freshly uploaded images don't work either, but they do on support-stage.
Can somebody in IT please take a look at where the uploaded images dir is on prod vs support-stage?
What I think has happened is that in moving the webroot we have a permissions issue.  

First, can IT confirm the /img/wiki-up directory (and image content) still exists and the location of it?  The content needs to be moved to /webroot/img/wiki-up.

There are two scripts that set file perms etc both in the webroot dir.  They are setup.sh and htaccess.sh.

I think we should run both of these:
sudo ./setup.sh nobody nobody
and
sudo ./htaccess.sh

My apologies, we should have documented this in the push bug, although I think we overlooked it because we didn't see a problem when we tested on support-stage.
Assignee: nobody → server-ops
corrections to directories: those should be [old document root]/img/wiki-up and [old document root]/webroot/img/wiki-up in my previous comment.
The directory webroot/img/wiki_up exists, and is writable to apache.  Note the underscore.  Does it need to be moved to a version with a hyphen, or was that a typo and that's not what the problem is?
Assignee: server-ops → justdave
That was a typo.
ok, in the old version, backups, dump, img/wiki and img/wiki_up are symlinks onto the netapp, in the new one they're local directories.  The files are all there on the netapp.

I did the following:

[root@mradm02 webroot]# rm -rf dump; ln -s /mnt/netapp/support.mozilla.org/dump [root@mradm02 webroot]# rm -rf backups; ln -s /mnt/netapp/support.mozilla.org/backups backups
[root@mradm02 webroot]# cd img
[root@mradm02 img]# rm -rf wiki; ln -s /mnt/netapp/support.mozilla.org/img/wiki
[root@mradm02 img]# rm -rf wiki_up; ln -s /mnt/netapp/support.mozilla.org/img/wiki_up
07:17:30 < laura> justdave:  I see screenshots too, yay!

The old version on stage appears to also have these symlinks, the new one does not.  It makes me a little nervous to create them on stage though because it has the production netapp mounted which means if you experiment on it you'd affect production.  Might be something to discuss with oremj.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Component: Knowledge Base Software → Server Operations
Product: support.mozilla.com → mozilla.org
QA Contact: kb-software → mrz
Version: unspecified → other
v
Thanks Dave!
Status: RESOLVED → VERIFIED
Product: mozilla.org → mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.