mochitest-chrome: intermittent "test_bug428288.html | Test timed out"

RESOLVED FIXED in mozilla2.0b7

Status

()

RESOLVED FIXED
10 years ago
6 years ago

People

(Reporter: myk, Assigned: philor)

Tracking

({intermittent-failure})

Trunk
mozilla2.0b7
x86
All
intermittent-failure
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
moz2-win32-slave08 turned orange this morning on:

TEST-UNEXPECTED-FAIL | chrome://mochikit/content/chrome/docshell/test/chrome/test_bug428288.html | Test timed out.
(Reporter)

Comment 1

10 years ago
The tinderbox turned green the next cycle.
Uh...  I don't see how that test can time out unless the browser crashes or the test harness is completely broken.  It doesn't even waitForExplicitFinish(): just runs some code and that's it.
Unless the load of the document in general timed out (say because disk load was through the roof or something).
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1241562873.1241569105.19472.gz
OS X 10.4 comm-central unit test on 2009/05/05 15:34:33
Blocks: 438871
OS: Windows XP → All
Summary: 358 ERROR TEST-UNEXPECTED-FAIL because test_bug428288.html timed out → mochitest-chrome: intermittent "test_bug428288.html | Test timed out"
Whiteboard: [orange]
(In reply to comment #4)
> http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1241562873.1241569105.19472.gz
> OS X 10.4 comm-central unit test on 2009/05/05 15:34:33

Full test log is
{
...
*** 424 INFO Running chrome://mochikit/content/chrome/docshell/test/chrome/test_bug428288.html...
*** 425 INFO TEST-PASS | chrome://mochikit/content/chrome/docshell/test/chrome/test_bug428288.html | Crashes if bug 428288 is present
NEXT ERROR *** 426 ERROR TEST-UNEXPECTED-FAIL | chrome://mochikit/content/chrome/docshell/test/chrome/test_bug428288.html | Test timed out.
*** 428 INFO Running chrome://mochikit/content/chrome/docshell/test/chrome/test_bug449778.xul...
...
}
(In reply to comment #5)
> *** 428 INFO Running
> chrome://mochikit/content/chrome/docshell/test/chrome/test_bug449778.xul...
> ...

Fwiw, test_bug449778.xul did not report anything on this run:
{
*** 428 INFO Running chrome://mochikit/content/chrome/docshell/test/chrome/test_bug449778.xul...
*** 430 INFO Running chrome://mochikit/content/chrome/docshell/test/chrome/test_bug449780.xul...
*** 431 INFO TEST-PASS | chrome://mochikit/content/chrome/docshell/test/chrome/test_bug449780.xul | Expected hide then show on first loaded page
}
whereas it usually does work as expected.
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1241591688.1241600291.32696.gz
WINNT 5.2 mozilla-central unit test on 2009/05/05 23:34:48

Comment 9

10 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1241668403.1241672909.23912.gz
Mac OS X mozilla-central unit test on 2009/05/06
This just happened on Mac:

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1242261742.1242264722.17345.gz
OS X 10.5.2 mozilla-central unit test on 2009/05/13 17:42:22

Comment 13

10 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox3.5/1242333381.1242341038.11991.gz
Linux mozilla-1.9.1 unit test on 2009/05/14 13:36:21
(Assignee)

Comment 14

9 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1258081555.1258086853.21997.gz#err0
WINNT 5.2 mozilla-central debug test everythingelse on 2009/11/12 19:05:55
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1260603687.1260609452.28990.gz#err0
WINNT 5.2 mozilla-central debug test everythingelse on 2009/12/11 23:41:27  
s: win32-slave28
(Assignee)

Comment 17

9 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1260739320.1260746416.20171.gz
WINNT 5.2 mozilla-central debug test everythingelse on 2009/12/13 13:22:00
s: win32-slave35
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1270593722.1270594118.29175.gz
OS X 10.5.2 mozilla-central opt test mochitest-other on 2010/04/06 15:42:02
s: bm-xserve18

I think this is the same bug -- the process was killed (by the harness due to a timeout?) during this same test:
{
2035 INFO Running chrome://mochikit/content/chrome/docshell/test/chrome/test_bug428288.html...
process killed by signal 30
program finished with exit code -1
}
Likewise, I think:

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1270593722.1270594118.29175.gz
OS X 10.5.2 mozilla-central opt test mochitest-other on 2010/04/06 15:42:02
s: bm-xserve18

2035 INFO Running chrome://mochikit/content/chrome/docshell/test/chrome/test_bug428288.html...
process killed by signal 30
program finished with exit code -1
elapsedTime=42.251634
TinderboxPrint: mochitest-chrome<br/><em class="testfail">T-FAIL</em>
Unknown Error: command finished with exit code: -1
Comment hidden (Treeherder Robot)
(Assignee)

Comment 21

9 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1274807690.1274808986.10409.gz
Linux mozilla-central opt test mochitest-other on 2010/05/25 10:14:50
s: moz2-linux-slave08

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1274807455.1274809092.10647.gz
Rev3 Fedora 12x64 mozilla-central debug test mochitest-other on 2010/05/25 10:10:55
s: talos-r3-fed64-014
(Assignee)

Comment 22

9 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1274808166.1274809876.13788.gz
WINNT 5.2 mozilla-central debug test mochitest-other on 2010/05/25 10:22:46
s: win32-slave27
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
We apparently went 10 weeks without seeing this between comment 32 and comment 33, and now it's back with a vengeance. If it's that much more reproducible now will there be enough evidence to fix it?
(Assignee)

Comment 75

8 years ago
<philor>: bz: does http://mxr.mozilla.org/mozilla-central/source/docshell/test/chrome/test_bug428288.html?force=1 actually need to be loading mozilla.com? I don't understand why it's a test for the bug, so I don't know whether we could maybe fix bug 464946 by having it load something more local
<bz>: it doesn't matter what it loads
<bz>: pretty sure about:blank would work there

Tryserver seems to agree that about:blank works (though the frequency isn't quite high enough to hit it on every push), and agrees that about:blank + the patch from bug 428288 reverted still properly crashes, so

http://hg.mozilla.org/mozilla-central/rev/192c38466579
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Assignee)

Comment 80

8 years ago
I think that's enough runs on mozilla-central and on tracemonkey to say that it's still happening quite a bit without my patch, and not happening with it. Worst comes to worst, we can always reopen.
Assignee: nobody → philringnalda
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → mozilla2.0b7
Keywords: intermittent-failure
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.