Closed Bug 465073 Opened 11 years ago Closed 11 years ago

duplicate id in navigator.xul: reporterItemsBroadcaster

Categories

(Other Applications Graveyard :: Reporter, defect)

defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED
mozilla1.9.1b2

People

(Reporter: kairo, Assigned: philip.chee)

References

Details

Attachments

(1 file, 1 obsolete file)

We have a chrome mochitest error since bug 428216 has been checked in, reporting reporterItemsBroadcaster as a duplicate ID in navigator.xul. This is caused by http://mxr.mozilla.org/comm-central/source/mozilla/extensions/reporter/resources/content/reporter/reporterOverlay.xul suddenly succeeding to overlay both its broadcaster definitions as http://hg.mozilla.org/comm-central/annotate/f46a87cfb094/suite/browser/navigator.xul#l115 was added by bug 428216.

We need to solve that in some way, which could even mean to remove the SeaMonkey-specific parts of the reporter overlay in mozilla-central.
I guess there are 2 ways:

1) Remove the broadcaster from navigator.xul
2) Accept some changes in the Help menu. In utilityOverlay.xul, we can use "menu_HelpPopup" instead of "helpPopup" and "releaseNotes" instead of "releaseURL".
(I'm going to try 2) and see how it looks)
Urm?? Why not just remove <broadcasterset id="navBroadcasters"> from reporterOverlay.xul?
(In reply to comment #3)
> Urm?? Why not just remove <broadcasterset id="navBroadcasters"> from
> reporterOverlay.xul?

Yeah, that might be better. I think we'll need a separate bug filed for that. Would you mind filing it?
Why do we need a separate bug for resolving this bug? If someone comes up with a patch and we decide it's actually reporter that needs to be fixed (I actually tend to agree on that), then Bugzilla has this cool feature of being able to just move the bug to that product/component.
That's why I filed that bug on the symptom, not the cause, as whatever fix fixes the symptom of the failing test fixes this bug.
I guess my mind was still at 2) in comment #1 (and that would have been this bug + another bug imo)
Version: unspecified → Trunk
Now that we have a "mainBroadcasterSet" we should simply remove "navBroadcasters".
Assignee: nobody → philip.chee
Attachment #348535 - Flags: review?(gavin.sharp)
Component: UI Design → Reporter
Product: SeaMonkey → Other Applications
QA Contact: ui-design → xul-client
Comment on attachment 348535 [details] [diff] [review]
Remove "navBroadcasters" from overlay

>diff --git a/extensions/reporter/resources/content/reporter/reporterOverlay.xul b/extensions/reporter/resources/content/reporter/reporterOverlay.xul

>+  <!-- All Applications -->

s/All Applications/SeaMonkey and Firefox/ ?
Attachment #348535 - Flags: review?(gavin.sharp) → review+
> s/All Applications/SeaMonkey and Firefox/ ?
I considered it but it looked too verbose. Perhaps we could remove this comment entirely as it's probably superfluous.
Too verbose? It's three words! :) I think it makes sense to be precise and explicitly state which apps the overlay was meant to support.
> Too verbose? It's three words! :) I think it makes sense to be precise and
> explicitly state which apps the overlay was meant to support.

Fixed comment to say <!-- Firefox and SeaMonkey -->
Carrying forward r+

I think that this is NPOTFB, nevertheless do I need a+ for landing in mozilla-central ATM?
Attachment #348535 - Attachment is obsolete: true
Attachment #348724 - Flags: review+
(In reply to comment #11)
> I think that this is NPOTFB, nevertheless do I need a+ for landing in
> mozilla-central ATM?

Approval is not needed for NPOTDB, but checkins are currently metered:
https://wiki.mozilla.org/1.9.1_beta_2_checkins
Go ahead and check it in whenever.
Keywords: checkin-needed
Whiteboard: [checkin comment 11]
Pushed as http://hg.mozilla.org/mozilla-central/rev/813830032772 with sheriff permission :)
Status: NEW → RESOLVED
Closed: 11 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Whiteboard: [checkin comment 11]
Tinderboxes went green after 2008/11/18 10:18:06.

V.Fixed
Status: RESOLVED → VERIFIED
Target Milestone: --- → mozilla1.9.1b2
Product: Other Applications → Other Applications Graveyard
You need to log in before you can comment on or make changes to this bug.