Deleting too many messages causes freeze

VERIFIED DUPLICATE of bug 17470

Status

P3
normal
VERIFIED DUPLICATE of bug 17470
18 years ago
10 years ago

People

(Reporter: johng, Assigned: Bienvenu)

Tracking

({perf})

Trunk
x86
Windows 95

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
build 2000072508 (also true with 0724 build), Win 95, using pop

This bug has to do with shift selecting hundreds of messages at one time then 
clicking "delete" to delete them all at once.  

When it doesn't work, there is definitely a visual freeze (no indication that 
anything is happening and user can't do anything), but I'm not 100% sure that 
the product actually freezes (sometimes it eventually finished deleting all the 
files and all was OK, but other times I think it may have actually frozen so I 
restarted).

First time I did this (build 072408), it was successful with good feedback.  
Namely, I selected several hundred old emails in my inbox (a contiguous 
selection with a few messages cntrl clicked out of that selection).  Then I 
pressed delete.  It was slow, but I saw the feedback in the folders pane of the 
number of messages in the inbox counting down while the # of messages in the 
trash slowly counted up.  There was no indication in the status bar (like we 
have in 4.x), but there was visual evidence that something was happening.

Note I could do nothing while these messages were being deleted - I had to sit 
there and watch this long process.  Nothing visual said "wait while deleting."

Second time I did this (again build 072408), it failed.  There was no visual 
indication that anything was happening and the product seemed to be frozen.  I 
restarted and tried to mass delete from the trash folder (a true delete), and 
again there was a visual and I think actual freeze.

Next day, used new build 2000072508, first tried deleting one message from the 
trash folder.  OK.  Then tried massively deleting.  No visual indication, and I 
think it froze it reality (not sure).  Restarted, went to trash again, saw that 
some of the messages massively selected had been deleted.  I tried massively 
selecting the rest (several hundred) and got the same no visual indication and 
throught the product was frozen.  However, I let it run and run and finally it 
did finish the process, successfully deleted all those messages, and let me use 
the product again.
(Reporter)

Comment 1

18 years ago
since this appears to be a product freeze, and sometimes might be, nominating 
nsbeta3.  From the users point of view, this appears as bad as a crash.
Keywords: nsbeta3
(Assignee)

Comment 2

18 years ago
My guess is this is tree control stuff that'll be fixed when hyatt fixes 17470.
It doesn't have anything to do with me, or the mail database code, so I'm
setting the component to mail back end. It's probably not even the mail back
end, but I'll leave it at that until 17470 is fixed.
Component: Mail Database → Mail Back End
Depends on: 17470
(Assignee)

Comment 3

18 years ago
changing summary - John meant messages, I'm sure.
Summary: Deleting too many files causes freeze → Deleting too many messages causes freeze

Comment 4

18 years ago
17470 is not being fixed.  perhaps we need to offer feedback, like a busy 
cursor.

Updated

18 years ago
QA Contact: lchiang → esther

Updated

18 years ago
Keywords: perf
(Assignee)

Comment 5

18 years ago
Marking a dup of 17440. 17470 is being fixed. Trudelle really didn't understand
the history or seriousness of 17470 but he relented in the face of my whining.
Hyatt fixed his part of it, and now the ball is in waterson's court because
we're thrashing in the xul template builder stuff.

*** This bug has been marked as a duplicate of 17470 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 6

18 years ago
Marking verified as a duplicate.
Status: RESOLVED → VERIFIED
QA Contact: esther → laurel
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.