Status

()

Firefox
General
--
major
RESOLVED DUPLICATE of bug 46845
9 years ago
9 years ago

People

(Reporter: Jose, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.4) Gecko/2008102920 Firefox/3.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.4) Gecko/2008102920 Firefox/3.0.4

The state of the radio button is being cached.  This is a very serious bug since you cannot trust the data you see.  I noticed this bug since 2007.  Is amazing that it is still there. Thats why I am writing this bug. Opera, Explorer and Safari work as exepected

Reproducible: Always

Steps to Reproduce:
1. Create a form with 2 radio button, checked the first one
2. Open the page in the browser
3. Now edit the file and change the check to the second radio
4. View the page again. IT DOES NOT SHOW THE CHANGE

It does not matter how many times you refresh, unless you force the refresh
Actual Results:  
radio state is the old one

Expected Results:  
The radio button should show the state that is in the html code

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<html>
<head>
<META HTTP-EQUIV="CACHE-CONTROL" CONTENT="NO-CACHE">
</head>
<body>
<form>
<input type="radio" value="M" name="Sex"  />Male
<input type="radio" value="F" name="Sex"  checked="checked"  />Female
</form>
</body>
</html>
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 46845
You need to log in before you can comment on or make changes to this bug.