Closed Bug 465597 Opened 16 years ago Closed 15 years ago

Undo Close Tab should also close the newly opened window

Categories

(Firefox :: Tabbed Browser, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: Peter6, Unassigned)

References

Details

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081118 Minefield/3.1b2pre ID:20081118112608

repro:
open an FF window (#1) with a few tabs
drag one tab off to open it in a new window (#2)
go to window #1
rightclick on the tabbar and select [Undo Close Tab]

result:
the dragged off tab is reopened in window #1
the same tab is also open in window #2

expected
the dragged off tab is reopened in window #1
window #2 to be closed because the tab there is back in window #1
I think it would make more sense for drag-detaching a tab to not add an entry to the recently-closed list at all (since it was never closed).  See also bug 394759.
what would the expected behavior be if you had navigated in the detached window? couldn't go closing the window unless undo was changed to mean reattach in current state. comment 1 sounds good :)
Closing as WORKSFORME on Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.3a1pre) Gecko/20090816 Minefield/3.7a1pre as tabs no longer appear in "Recently Closed Tabs" on detach.  Please reopen if you see this on trunk on Windows.
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → WORKSFORME
Depends on: 490040
You need to log in before you can comment on or make changes to this bug.