Closed Bug 465662 Opened 12 years ago Closed 9 years ago

remove libreg from toolkit

Categories

(Toolkit Graveyard :: Build Config, defect)

x86
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: dougt, Unassigned)

References

Details

Attachments

(1 file, 1 obsolete file)

The only consumer of libreg is browser/migration.  We should consider moving this functionality out of toolkit and basically make the browser makefiles.sh create the makefiles for libreg instead of toolkit.

This is ideal since mobile doesn't need libreg and for windows mobile, we have some build bustages in that code.
Assignee: nobody → doug.turner
Attached patch patch v.1 (obsolete) — Splinter Review
something like this.
(In reply to comment #0)
> The only consumer of libreg is browser/migration.

s/browser/browser,mail,suite,mailnews/
not mobile, songbird.  it would be good to have a configure flag or something.
You could add an AC_SUBST(MOZ_LIBREG) in configure.in, and have apps opt in in their confvars.sh.
Plugins don't use libreg for pluginreg.dat any more?
(In reply to comment #5)
> Plugins don't use libreg for pluginreg.dat any more?

Doesn't appear to. It uses nsPluginManifestLineReader, which has no dependencies on libreg.
so, can we move this out of toolkit?
Yes, I think so. We should continue to build the static library always as part of the xulrunner build process, but there's no need to link it to libxul.
bsmedberg, can you take a look at the patch?
Attachment #348917 - Flags: review?(benjamin)
Attachment #348917 - Flags: review?(benjamin) → review-
Comment on attachment 348917 [details] [diff] [review]
patch v.1

I think we should build libreg from the XR build system even when it might not be used.
yeah, that removes my motivation from fixing this.  I do not want to build libreg on WINCE.  There were a bunch of problems with libreg building on WINCE and given that we do not use it, I didn't look at fixing them.

Why build something we don't use?
You don't have to build it on WinCE. I just want it to keep building otherwise because a fair number of apps use it, and getting them each to build it is pretty hard...
Flags: wanted1.9.1?
it doesn't look like we/fennec needs this any longer.  we are successfully building as is.
Assignee: doug.turner → nobody
Duplicate of this bug: 479105
Here's a patch to disable it when building on CE.  Doug, I think you're building with --disable-xpinstall, which causes it to not be needed... though now that I think about it, we don't need xpinstall for my use anyway.  However, we may as well fix this so that things don't break if someone doesn't specify the disable.

I don't really agree that we should keep building this for other platforms -- if other apps need it, they should take ownership of it; but disabling it here fixes the immediate problem.
Attachment #348917 - Attachment is obsolete: true
Attachment #366249 - Flags: review?(benjamin)
Attachment #366249 - Flags: review?(benjamin) → review+
clearing 1.9.1 request
Flags: wanted1.9.1?
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 679352
This is not exactly a duplicate of that bug, however is useless now :)
Resolution: DUPLICATE → INVALID
Product: Toolkit → Toolkit Graveyard
You need to log in before you can comment on or make changes to this bug.