Port bug 391728 (disabled plugin placeholder) UI to SeaMonkey

VERIFIED FIXED in seamonkey2.0

Status

SeaMonkey
UI Design
VERIFIED FIXED
10 years ago
9 years ago

People

(Reporter: Robert Kaiser, Assigned: neil@parkwaycc.co.uk)

Tracking

({fixed-seamonkey2.0})

Trunk
seamonkey2.0
fixed-seamonkey2.0
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
bug 391728 added some Firefox-specific UI stuff that SeaMonkey probably needs to port.

Comment 1

10 years ago
Also Bug 462965 - Land disabled plugin and blocked plugin icons
Depends on: 458512
(Reporter)

Comment 2

9 years ago
Bug 484188 adds tests for plugins, one part I marked todo() there is probably connected with this.
Blocks: 484188, 467530
Keywords: student-project
Whiteboard: [good first bug]
(Reporter)

Updated

9 years ago
Duplicate of this bug: 519742
(Reporter)

Updated

9 years ago
Flags: wanted-seamonkey2.0?
(Assignee)

Comment 4

9 years ago
Created attachment 404022 [details] [diff] [review]
Proposed patch

Only picking KaiRo because of test changes. Feel free to redirect if necessary.
Assignee: nobody → neil
Status: NEW → ASSIGNED
Attachment #404022 - Flags: review?(kairo)
(Reporter)

Comment 5

9 years ago
Comment on attachment 404022 [details] [diff] [review]
Proposed patch

Thanks for taking this on, works fine!
Attachment #404022 - Flags: review?(kairo) → review+
(Reporter)

Comment 6

9 years ago
Comment on attachment 404022 [details] [diff] [review]
Proposed patch

>+            var theEM = Components.classes["@mozilla.org/appshell/window-mediator;1"]
>+                                  .getService(Components.interfaces.nsIWindowMediator)
>+                                  .getMostRecentWindow("Extension:Manager");
>+
>+            if (theEM) {
>+              theEM.focus();
>+              theEM.showView("plugins");
>+              return;
>+            }
>+
>+            const EMURL = "chrome://mozapps/content/extensions/extensions.xul";
>+            const EMFEATURES = "all,dialog=no";
>+            window.openDialog(EMURL, "", EMFEATURES, "plugins");

As a note, you probably could have gone through toEM("plugins") here as well, but I'll leave it up to you which way you like better.
(Reporter)

Updated

9 years ago
Attachment #404022 - Flags: approval-seamonkey2.0+
(Reporter)

Updated

9 years ago
Flags: wanted-seamonkey2.0?
(Assignee)

Comment 7

9 years ago
(toEM isn't guaranteed to be available from notification.xml)
(Assignee)

Comment 8

9 years ago
Pushed changeset 12859ee80820 to comm-central.
Keywords: student-project → fixed-seamonkey2.0
Whiteboard: [good first bug]
(Assignee)

Updated

9 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
No longer blocks: 467530
Flags: in-testsuite+
Target Milestone: --- → seamonkey2.0

Comment 9

9 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.4pre) Gecko/20091002 SeaMonkey/2.0pre

It's work fine, now.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.