Last Comment Bug 465814 - Not all images load on a page with pipelining enabled
: Not all images load on a page with pipelining enabled
Status: RESOLVED WONTFIX
:
Product: Core
Classification: Components
Component: Networking: HTTP (show other bugs)
: Trunk
: PowerPC Mac OS X
: -- major (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
http://old.chmi.cz/meteo/ov/aladin/re...
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-19 13:36 PST by Honza Bambas (:mayhemer)
Modified: 2016-01-08 11:01 PST (History)
8 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Honza Bambas (:mayhemer) 2008-11-19 13:36:55 PST
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9.1b2pre) Gecko/20081119 Minefield/3.1b2pre ID:20081119053142 and earliers.

STR (~80-90% reproducible):
- go to URL
- check the "zobrazit všechy mapy" check box at the top, page will automatically reload

Bug:
some images hang or don't load and appear as broken, after manual reload or whole page reload they appear

Expected:
all images load on the first page load

Will investigate, not probable it is my home net config problem.
Comment 1 Tyler Downer [:Tyler] 2008-11-19 13:52:24 PST
Please read http://new.quality.mozilla.org/bug-writing-guidelines.
Comment 2 Honza Bambas (:mayhemer) 2008-11-19 15:15:53 PST
Oops, caused by pipelining turned on manually. I get broken images also on FF 3.0.4 with that preference, and what is worse, the image is load just partially instead of a broken image icon appearing (I recall I was trying to fix this problem with https sites some time ago, bug 422978). 

The server is:
Server: Apache/2.0.54 (Unix) PHP/4.4.0
X-Powered-By: PHP/4.4.0

witch chunked encoding. There are some regularly lost packets and retransmissions as seen in Wireshark. Question is why the traffic stops at all. Probably a server problem?

This info could be important for Fennec developers because they use pipelining on by default.
Comment 3 Honza Bambas (:mayhemer) 2009-01-09 07:57:45 PST
CCing some Fennec people. If this bug is not interesting for them we could potentially close it.
Comment 4 Patrick McManus [:mcmanus] PTO until Sep 6 2009-01-10 06:38:51 PST
This could be interesting as a test case to find a workaround for, though as usual I'm sure the problem is server side. (Actually it is almost always in a transparent intermediary)

however, the url you posted doesn't really have more than 1 image in it:
http://www.chmi.cz/meteo/ov/aladin/results/index.php

I can't read Czech(?) but I just clicked on something random and got this page: http://www.chmi.cz/meteo/ov/aladin/results/index.php?run=latest&ff=on

that does have a bunch of images (topo maps?), but they all load fine for me with pipelining on both fennec and firefox 3.0.5

Can you include the packet trace that you are looking at in wireshark so I can see the problem manifested?
Comment 5 Honza Bambas (:mayhemer) 2009-01-12 06:05:59 PST
www.chmi.cz is the Czech Hydro Meteorologic Institute official site. The URL I refer to is the Aladin numeric model weather forecast for 2 upcoming days. The maps of czech republic with temperatures, humidity, wind and cloudy situation loads when you check the "zobrazit všechy mapy" check box at the top (as you probably did).

PCAPs are here: http://www.janbambas.cz/mozilla/bugs/465814.ZIP. For me it still doesn't work, but only with Shiretoko and on MAC. I have checked with my provider they are not using any transparent proxy.
Comment 6 Patrick McManus [:mcmanus] PTO until Sep 6 2009-01-12 06:12:19 PST
(In reply to comment #5)

> PCAPs are here: http://www.janbambas.cz/mozilla/bugs/465814.ZIP. For me it
> still doesn't work, but only with Shiretoko and on MAC. 

thanks for the info. I can try that UA setup too.

> I have checked with my
> provider they are not using any transparent proxy.

fwiw in my experience just as of then the transparent device is a load balancer or other kind of smart switch at the server location as it is something from the IP provider (or any of their upstreams). It isn't uncommmon to find people not even aware they are running them.
Comment 7 John Vandenberg 2010-10-22 02:54:35 PDT
WFM on Windows/Linux 3.6.11 and
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9.2.11) Gecko/20101012 Firefox/3.6.11
Comment 8 Patrick McManus [:mcmanus] PTO until Sep 6 2011-01-13 07:30:28 PST
I think the code in 599164 probably addresses this, but I cannot really reproduce the original problem with any consistency.
Comment 9 Shane Bundy 2012-07-31 06:30:38 PDT
This still occurs for images using HTTP SSL pipelining.

Note You need to log in before you can comment on or make changes to this bug.