Recreating Preferences Manager on shutdown

RESOLVED FIXED in Camino2.0

Status

Camino Graveyard
Preferences
RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: Chris Lawson (gone), Assigned: Chris Lawson (gone))

Tracking

({regression})

unspecified
Camino2.0
All
Mac OS X
regression

Details

Attachments

(1 attachment)

(Assignee)

Description

9 years ago
Smokey thinks smfr fixed this at least once before, though I can't find anything.

Debug builds, as of sometime in the last couple months, are logging "Recreating preferences manager on shutdown!" when quit. I don't know if it's a serious problem, but I'm pretty sure the cause is this, from the patch on bug 384689:

 - (void) dealloc
 {
   [[NSNotificationCenter defaultCenter] removeObserver:self];
+  [[PreferenceManager sharedInstance] removeObserver:self forPref:kGeckoPrefInlineLocationBarAutocomplete];
   [self cleanup];
   [super dealloc];
 }

Do we actually need to remove the Gecko pref observer since the PreferenceManager has already been destroyed at that point? I assumed we did, but maybe we don't.

Comment 1

9 years ago
Oops, that's definitely bad. We should be using sharedInstanceDontCreate instead.
Target Milestone: --- → Camino2.0
(Assignee)

Comment 2

9 years ago
Created attachment 349116 [details] [diff] [review]
fix v1.0

That oughta do it. Sorry 'bout that.
Assignee: nobody → cl-bugs-new
Status: NEW → ASSIGNED
Attachment #349116 - Flags: superreview?(stuart.morgan+bugzilla)

Updated

9 years ago
Attachment #349116 - Flags: superreview?(stuart.morgan+bugzilla) → superreview+

Comment 3

9 years ago
Comment on attachment 349116 [details] [diff] [review]
fix v1.0

sr=smorgan
Chickens wrangled.
Blocks: 384689
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Keywords: regression
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.