Closed Bug 465917 Opened 11 years ago Closed 11 years ago

Usability: Involuntary mouse movement is constantly detaching tabs

Categories

(Firefox :: Tabbed Browser, defect, trivial)

x86
Windows XP
defect
Not set
trivial

Tracking

()

RESOLVED DUPLICATE of bug 465346

People

(Reporter: arancaytar.ilyaran, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081119 Minefield/3.1b2pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081119 Minefield/3.1b2pre

In the latest release, you've done a wonderful job of making the interface respond to new drag-and-drop actions. Unfortunately, as I am browsing with my laptop's touchpad, I find myself making an involuntary gesture very often:

When trying to close or activate a tab, the mouse will sometimes trigger a drag event rather than a clicking one, and by dragging the tab even the tiniest distance out of the narrow tab bar, it is detached into its own window.

This detachment and creation of a new window is profoundly disruptive, and is also a very slow and work-intensive operation for the computer which makes it even more annoying. I then have to drag the tab back into the original tab bar and continue browsing until it happens again.

I recognize that it's not nice to hear a new feature can be a PITA, but could you please think of ways to make it less easy to trigger it by accident? Even a simple confirmation prompt would suffice, though ideally I'd like an option to turn it off completely, and detach tabs only through the context menu. Thanks!

Reproducible: Always

Steps to Reproduce:
1. Open several tabs
2. Click on one of them
3. Drag it a little bit up or down due to your clumsy mouse
Actual Results:  
The tab vanishes mysteriously. You wait for up to 10 seconds, when suddenly a new window opens, containing your tab. You will need to either close this window and reopen the page, or somehow drag your tab back.

Expected Results:  
Nothing happens because you opted out of detaching the tab with drag-and-drop.
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 465346
You need to log in before you can comment on or make changes to this bug.