Closed Bug 466156 Opened 11 years ago Closed 11 years ago

Tab opened in a new window without any reason

Categories

(Firefox :: Tabbed Browser, defect, major)

x86
Windows XP
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 465346

People

(Reporter: jerome, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081120 Minefield/3.1b2pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081120 Minefield/3.1b2pre

I opened several tabs in my Firefox windows (currently, I have 3 windows opened with around 4 tabs in each of them).
I'm doing my stuff as usual, and sometimes, without any reason, the selected tab opens itself in a new window and disappear from the soriginal one.
It happens since last monday nov. 17th's version.

Reproducible: Sometimes

Steps to Reproduce:
1. Open several windows with several tabs inside
2. Do what you do normally with your browser
3. Be patient ;)
Actual Results:  
Sometimes, the selected tab opens itself in a new window.

Expected Results:  
The selected tab is suppose to stay in its parent window.

I couldn't figure if there is a common pattern to the different times it happened to me (around 10 or 15 times in 5 days).
Are you sure you didn't click on and very slightly drag (1 or 2 pixels) the tab?

I've been doing that a lot since bug 225680 (in fact it just happened while writing this comment).

In which case you're covered by bug 465184 and bug 465346
Maybe, but the fact it happens a lot makes me suspicious...
I'll try to be more attentive to see if it comes to my way to use hte browser or from an actual bug.
It just happened right now and I'm sure it's a bug.
It happened when I refreshed a page, the tab opened in a new window.
And thinking of that, I guess it almost always happened when I clicked on refresh.
Tried reproducing by clicking refresh a lot but I can't. Do you have any add-ons installed? If so could you try reproducing it with them off or in Firefox safemode:

http://support.mozilla.com/en-US/kb/Safe+Mode
Version: unspecified → Trunk
I use the nightly version with only Firebug installed on it.
I'll try on safe mode and see if it happens again.
After more testing, it appears it may be because I move the mouse quickly and the tab is dragged a little bit when I select it, so, it opens in a new window.
That's a bit disturbing, but it's only I have to be used to that.
If there's a way to make this feature a bit less sensitive, it would be good, but if not, it's OK.
So, I'll mark this bug as resolved.
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → INVALID
That really makes it a duplicate of this bug, it's certainly not invalid.
Resolution: INVALID → DUPLICATE
Duplicate of bug: 465346
You need to log in before you can comment on or make changes to this bug.