Closed Bug 466169 Opened 14 years ago Closed 13 years ago

Pop-ups/context menus are wrongly positioned if browser window is displayed over 2 screens

Categories

(Firefox :: Menus, defect)

defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: nugg, Unassigned)

References

()

Details

Attachments

(1 file, 1 obsolete file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; de-DE; rv:1.9.0.4) Gecko/2008102920 Firefox/3.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; de-DE; rv:1.9.0.4) Gecko/2008102920 Firefox/3.0.4

When the Firefox window is stretched over 2 screens and you click on the tabmenu on the second screen it displays the popupmenu on screen one when the most of the window is on screen one.

Reproducible: Always

Steps to Reproduce:
1. open Firefox
2. stretch the window so that most of it is on screen 1 and some on screen 2
3. open a few tabs (e.g. with ctrl+t)
4. rightclick on the last tab
Actual Results:  
popupmenu opens at the end of screen 1 (x-coordinates are wrong) which isn't even close to the mouseposition

Expected Results:  
it should open next to the mouse
Summary: Firefox-window stretched over 2 screens rightclick on tabmenu displays popupmenu on screen 1 → Firefox-window stretched over 2 screens rightclick on tabmenu displays popupmenu / contextmenu on screen 1
Severity: trivial → normal
Try in Safe Mode or with a new profile. Maybe give a screenshot if possible. Does the menu appear in the right spot when you click on screen one?
Its the same for save mode screenshot is already there take a look at URL link above. The menu appears at the first screen right side at the same y coordinate as the mouse.
Please place screenshots on the bug itself.
Attached image wrong screenshot :P (obsolete) —
Comment on attachment 352752 [details]
wrong screenshot :P

wrong screenshot
Attachment #352752 - Attachment description: 2 screens, contextmenu on first screen, mouse on second screen, clicked last tab → wrong screenshot :P
Attachment #352752 - Attachment filename: shoozzavs7.jpg → random screeny.jpg
Attachment #352752 - Attachment is obsolete: true
Summary: Firefox-window stretched over 2 screens rightclick on tabmenu displays popupmenu / contextmenu on screen 1 → generall positioning bug Firefox-window stretched over 2 screens rightclick on tabmenu or searchbar displays popupmenu / contextmenu on screen 1
Yeah, that happens on OS X too. Any popup is displayed on the screen where Firefox has been launched.

Steps:
1. Start Firefox on a computer with a dual screen setup
2. Open the context menu on the screen where Firefox is started
3. Move the window in the middle of both screens
4. Open the context menu on the other screen

In step 2 everything looks fine. But doing the same in step 4 the context menu is glued to the edge of the other screen and is not displayed at the mouse position.

Confirming.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows Vista → All
Hardware: x86 → All
Version: unspecified → Trunk
Summary: generall positioning bug Firefox-window stretched over 2 screens rightclick on tabmenu or searchbar displays popupmenu / contextmenu on screen 1 → Pop-ups/context menus are wrongly positioned if browser window is displayed over 2 screens
Duplicate of this bug: 498740
Duplicate of this bug: 498737
anyone see this with trunk build? 

WFM, with trunk. It only goes on left monitor if the widget spans the monitors. IE. google search or bookmark drop downs that are entirely on the right, stay on the right.
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.3a1pre) Gecko/20090909 Minefield/3.7a1pre
Both pop-up and context menu work as expected with 20091007 Minefield/3.7a1pre.

The pop-up follows the position of main part of the browser window. It appears on monitor (I) if the browser window displayed mainly on monitor I. So does for Monitor (II).

Normally I block any pop-up. Unblocked and tested it just now.
I have to second the above comments. It even looks good on 1.9.2 with Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2b1pre) Gecko/20091007 Namoroka/3.6b1pre ID:20091007034618

As long as we don't know the real implementation bug lets close it as WFM.
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.