Closed Bug 466367 Opened 11 years ago Closed 11 years ago

Receiving acceptation from a Windows Lightning to a Linux version results in a garbled e-mail with no reaction on calendar

Categories

(Calendar :: E-mail based Scheduling (iTIP/iMIP), defect, major)

Lightning 0.9
defect
Not set
major

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: esa.ahonen, Assigned: dbo)

References

Details

Attachments

(1 file)

User-Agent:       Opera/9.61 (X11; Linux i686; U; en) Presto/2.1.1
Build Identifier: 

Receiving an accept for an event is garbled. Sender is using latest version available now (2008-11-23) on Windows XP and latest Thunderbird.

Receiving it on an Linux machine (version 2.0.0.16 (20080725)) and lightning 0.9 (build 2008091718) gives and e-mail that is a mess, not any intelligent sign of confirmation.

Reproducible: Always

Steps to Reproduce:
1. Send an invitation on Linux machine (versions described above)
2. Send an accept on Windows machine (versions described above)
3. Receive an garbled acceptation
Actual Results:  
The received acceptation looks like this:

=?UTF-8?B?U3ViamVjdDogRXZlbnQgSW52aXRhdGlvbiBSZXBseTogRXNhbiBqYSA=?=
 =?UTF-8?B?TmlpbmFuIGjDpMOkcMOkaXbDpA==?=
Content-type: multipart/mixed; boundary="Boundary_(ID_qyG4ZdjoAsiZ+Jo19dCbWQ)"


--Boundary_(ID_qyG4ZdjoAsiZ+Jo19dCbWQ)
Content-type: multipart/alternative;
 boundary="Boundary_(ID_ryU4ZdJoASiZ+Jo21dCbwA)"


--Boundary_(ID_ryU4ZdJoASiZ+Jo21dCbwA)
Content-type: text/plain; charset=UTF-8
Content-transfer-encoding: 8BIT

[email-address] has accepted your event invitation.


--Boundary_(ID_ryU4ZdJoASiZ+Jo21dCbwA)
Content-type: text/calendar; method=REPLY; charset=UTF-8
Content-transfer-encoding: 8BIT

BEGIN:VCALENDAR
PRODID:-//Mozilla.org/NONSGML Mozilla Calendar V1.1//EN
VERSION:2.0
METHOD:REPLY
BEGIN:VTIMEZONE
TZID:Europe/Helsinki
X-LIC-LOCATION:Europe/Helsinki
BEGIN:DAYLIGHT
TZOFFSETFROM:+0200
TZOFFSETTO:+0300
TZNAME:EEST
DTSTART:19700329T030000
RRULE:FREQ=YEARLY;INTERVAL=1;BYDAY=-1SU;BYMONTH=3
END:DAYLIGHT
BEGIN:STANDARD
TZOFFSETFROM:+0300
TZOFFSETTO:+0200
TZNAME:EET
DTSTART:19701025T040000
RRULE:FREQ=YEARLY;INTERVAL=1;BYDAY=-1SU;BYMONTH=10
END:STANDARD
END:VTIMEZONE
BEGIN:VEVENT
CREATED:20081123T135150Z
LAST-MODIFIED:20081123T135418Z
DTSTAMP:20081123T135418Z
UID:8668a49c-9200-4eaf-ad79-f0d19f6bf133
SUMMARY:Esan ja Niinan hääpäivä
ORGANIZER;RSVP=TRUE;CN=Esa Ahonen;PARTSTAT=ACCEPTED;ROLE=CHAIR:mailto:
 [email-address]
ATTENDEE;CN=Matti Ahonen;PARTSTAT=ACCEPTED:mailto:[email-address]
DTSTART;TZID=Europe/Helsinki:20081204T180000
DTEND;TZID=Europe/Helsinki:20081204T210000
LOCATION:Saslik
SEQUENCE:0
END:VEVENT
END:VCALENDAR


--Boundary_(ID_ryU4ZdJoASiZ+Jo21dCbwA)--

--Boundary_(ID_qyG4ZdjoAsiZ+Jo19dCbWQ)
Content-type: application/ics; name=invite.ics
Content-transfer-encoding: 8BIT
Content-disposition: attachment; filename=invite.ics

BEGIN:VCALENDAR
PRODID:-//Mozilla.org/NONSGML Mozilla Calendar V1.1//EN
VERSION:2.0
METHOD:REPLY
BEGIN:VTIMEZONE
TZID:Europe/Helsinki
X-LIC-LOCATION:Europe/Helsinki
BEGIN:DAYLIGHT
TZOFFSETFROM:+0200
TZOFFSETTO:+0300
TZNAME:EEST
DTSTART:19700329T030000
RRULE:FREQ=YEARLY;INTERVAL=1;BYDAY=-1SU;BYMONTH=3
END:DAYLIGHT
BEGIN:STANDARD
TZOFFSETFROM:+0300
TZOFFSETTO:+0200
TZNAME:EET
DTSTART:19701025T040000
RRULE:FREQ=YEARLY;INTERVAL=1;BYDAY=-1SU;BYMONTH=10
END:STANDARD
END:VTIMEZONE
BEGIN:VEVENT
CREATED:20081123T135150Z
LAST-MODIFIED:20081123T135418Z
DTSTAMP:20081123T135418Z
UID:8668a49c-9200-4eaf-ad79-f0d19f6bf133
SUMMARY:Esan ja Niinan hääpäivä
ORGANIZER;RSVP=TRUE;CN=Esa Ahonen;PARTSTAT=ACCEPTED;ROLE=CHAIR:mailto:
 [email-address]
ATTENDEE;CN=Matti Ahonen;PARTSTAT=ACCEPTED:mailto:[email-address]
DTSTART;TZID=Europe/Helsinki:20081204T180000
DTEND;TZID=Europe/Helsinki:20081204T210000
LOCATION:Saslik
SEQUENCE:0
END:VEVENT
END:VCALENDAR


--Boundary_(ID_qyG4ZdjoAsiZ+Jo19dCbWQ)--

Expected Results:  
An reasonable acceptation.
Version: unspecified → Sunbird 0.9
Duplicate of this bug: 466366
Version: Sunbird 0.9 → Lightning 0.9
WFM. Could anybody confirm this issue?
I could confirm the issue using german umlauts in event title. Seems to be an encoding issue.
Assignee: nobody → daniel.boelzle
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Flags: blocking-calendar1.0+
Attached patch fix - v1Splinter Review
The mime converter service seems to encode the whole header (including the field name) for long headers with e.g. umlauts. This patch works around that, excluding the field name. Better solutions welcome...
Attachment #350317 - Flags: review?(bugzilla)
Thanks, I think I'll work around this, know that I know what is the cause - until it comes to a next release. Too busy to compile stuff just now - sorry. But thanks for tracking it down.
Comment on attachment 350317 [details] [diff] [review]
fix - v1

Bienvenu knows the mime code/interfaces better than I do.
Attachment #350317 - Flags: review?(bugzilla) → review?(bienvenu)
Comment on attachment 350317 [details] [diff] [review]
fix - v1

seems OK...
Attachment #350317 - Flags: review?(bienvenu) → review+
Summary: Receiving acceptation from Windows version of Lightning to Linux version results a garbled e-mail with no reaction on calendar → Receiving acceptation from a Windows Lightning to a Linux version results in a garbled e-mail with no reaction on calendar
Pushed to comm-central <http://hg.mozilla.org/comm-central/rev/a9abcbb479da>

-> FIXED
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
OS: Linux → All
Hardware: PC → All
Resolution: --- → FIXED
Target Milestone: --- → 1.0
Checked in lightning build 20081130 -> VERIFIED.
Status: RESOLVED → VERIFIED
These bugs are likely targeted at Lightning 1.0b1, not Lightning 1.0. If this change was done in error, please adjust the target milestone to its correct value. To filter on this bugspam, you can use "lightning-10-target-move".
Target Milestone: 1.0 → 1.0b1
You need to log in before you can comment on or make changes to this bug.