Status

()

Core
CSS Parsing and Computation
P3
enhancement
VERIFIED INVALID
18 years ago
18 years ago

People

(Reporter: hand, Assigned: Pierre Saslawsky)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Want CSS3 Selectors implemented in mozilla.  Of particular importance is the 
last-child pseudo class, followed by the subject pseudo class.  May have 
potential uses in XUL widgets.
Um, CSS3 is not yet complete. Unless you have a magic crystal ball to tell the
future, we cannot implement CSS3 selectors, since we don't know what they are.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID

Comment 2

18 years ago
Verified invalid.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 3

18 years ago
Yeah, CSS3 isn't finish yet - and perhaps CSS3 selectors like :subject will 
change by the time CSS3 is finished, so it probably isn't wise to implement 
that just yet.

However, since "last-child" pseudo class already has a corresponding "first-
child" pseudo class in CSS2, I think there is an extremely good chance that 
this particular CSS3 selector will remain the same in the final 
recommendation.  The implementation of "last-child" should be so similar 
to "first-child" there shouldn't be any design issues preventing it from being 
implementing now either.

http://www.w3.org/TR/css3-selectors.html
In that case file a bug for that separately. Note however that we have passed 
the feature-freeze stage so it won't be added in this release.
You need to log in before you can comment on or make changes to this bug.