Closed Bug 466501 Opened 11 years ago Closed 11 years ago

Wanted: "Open in NEXT tab" to open a new tab after the current tab, as opposed to "Open in LAST tab", which we currently have

Categories

(Firefox :: Tabbed Browser, enhancement)

PowerPC
macOS
enhancement
Not set

Tracking

()

RESOLVED DUPLICATE of bug 465673

People

(Reporter: michael-bugzilla-firefox, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.5; en-US; rv:1.9.0.3) Gecko/2008092414 Firefox/3.0.3
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.5; en-US; rv:1.9.0.3) Gecko/2008092414 Firefox/3.0.3

While reading a page where I want to open a followup tab, I want that tab to be "next". Right now it goes at the end.

Even better, if I'm opening 5 different tabs while reading one page, I want those to be the next five tabs, opened in order.

The first gives LIFO; the second gives "depth first". The current (open the tab at the end of the list) gives "breath first" or FIFO.

Reproducible: Always

Steps to Reproduce:
1. Open some tabs.
2. Close that first tab, and start reading the second one.
3. Open more tabs relevant to the current page.

Actual Results:  
Tabs relevant to the current page are at the end of the list of tabs

Expected Results:  
Tabs relevant to the current page are after the current page, before the rest of them.
This may be a dupe of an existing bug, I will look.
Meanwhile this extension accomplishes what you want:
https://addons.mozilla.org/en-US/firefox/addon/1956
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 465673
You need to log in before you can comment on or make changes to this bug.