Closed Bug 466651 Opened 13 years ago Closed 13 years ago

CSS overflow properties malfunction after 32768 height limit

Categories

(Firefox :: General, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 215055

People

(Reporter: chris, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-GB; rv:1.9.0.4) Gecko/2008102920 Firefox/3.0.4 FirePHP/0.2.1
Build Identifier: Latest stable Firefox 3.0.4 on Windows (completely certain about this)

If an element is set with:
overflow-y: auto
or
overflow-y: hidden
or
overflow: auto
(but not overflow: hidden)

and has a height over 2^15=32768 (I think it will be this, I actually roughly measured about 33000), then everything within the element after this height does not render. The element height is correctly rendered, just the contents is cropped.

This definitely does not happen on the Mac Firefox, and I now have 3 separate people seeing the problem, in 2 separate HTML contexts. I've narrowed it down to the CSS given (removing all other CSS).

Reproducible: Always

Steps to Reproduce:
See attached HTML file in this topic:
http://ocportal.com/forum/topicview/misc/9921.htm

Make sure you're testing on Windows.
Actual Results:  
Blanking out of significant portion of page.

Expected Results:  
Normal rendering, as on Firefox on Mac, or Internet Explorer.
Ignore the UA posted above. I posted the bug from a different browser.
=> duplicate of bug 215055
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: big-long-large-32767
You need to log in before you can comment on or make changes to this bug.