shell should output message when runs out of memory instead of or before os says Bus Error

VERIFIED DUPLICATE of bug 480029

Status

Tamarin
Garbage Collection (mmGC)
VERIFIED DUPLICATE of bug 480029
9 years ago
9 years ago

People

(Reporter: Dan Schaffer, Assigned: Tommy Reilly)

Tracking

(Blocks: 1 bug)

unspecified
flash10.1
x86
Mac OS X
Bug Flags:
wanted-flashplayer10 +
flashplayer-qrb +
flashplayer-triage +

Details

(Reporter)

Description

9 years ago
currently the shell crashes when runs out memory with no message.  e.g.
$ avmshell -memlimit 1 foo.abc
Bus Error (or Segmentation Fault on windows)

As part of the out of memory feature can we output a message like "heap memory limit exceeded" or "out of memory".

Currently when performance tests run out of memory we can't really tell whether its out of memory or a different crash.  this feature was talked about as part of the oom feature.
Flags: wanted-flashplayer10+
Flags: flashplayer-triage+
Flags: flashplayer-qrb?

Updated

9 years ago
Assignee: nobody → treilly
Status: NEW → ASSIGNED
Flags: flashplayer-qrb? → flashplayer-qrb+
Target Milestone: --- → flash10.x

Updated

9 years ago
Blocks: 472712
(Assignee)

Comment 1

9 years ago
how about exiting with a non-zero exit status, would that be enough?

Comment 2

9 years ago
Since one of the requirements for (some) clients of Tamarin is - or at least I thought it was - to clean up and exit in an orderly manner when Tamarin goes OOM, it seems that there needs to be some sort of callback or status code from the GC to the client code anyway.  If the client is the shell then it should IMO make use of this and in fact print such an message.

Updated

9 years ago
Blocks: 478870

Updated

9 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 480029

Updated

9 years ago
Status: RESOLVED → VERIFIED

Updated

9 years ago
No longer blocks: 478870
You need to log in before you can comment on or make changes to this bug.