Loading frameset causes previous page's content to move before disappearing

VERIFIED DUPLICATE of bug 34283

Status

()

P3
normal
VERIFIED DUPLICATE of bug 34283
18 years ago
26 days ago

People

(Reporter: jesup, Assigned: pollmann)

Tracking

Trunk
x86
FreeBSD
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
To re-create (preferably on a slower machine):  Go to mozilla.org.  Go to
www.gopconvention.org (or other page with frames, especially along the left
edge.)  Note that for a second the previous page's content all moves to the
right before being erased.

Visually, this is quite unappealing.  It also may give some problems due to
extra bandwidth use when the display is not local to the browser.  Also, it
really shouldn't be being done - the page should be cleared before the new page
starts to render it's frameset.  I.e. a frameset should clear it's window, not
just count on the frames to clear their portion of the window (which I'm
guessing is what is happening).

Comment 1

18 years ago
I'd guess the frames objects are copies of the object showing the main page
(still containing the last page viewed). As they are created, and repainted,
they still show that page until they are properly initialised with the wanted
page. Perhaps a clean frame should be kept in memory to copy the new frame
objects from.
(Reporter)

Comment 2

18 years ago
That sounds correct, and it sounds like a reasonable solution (clean frame
object) if there isn't a way to simply create one (I'm guessing you're correct
and it's being dup'ed from the current frame object).

This might be related to bug 46646.
Confirming for evaluation.

Gerv
Status: UNCONFIRMED → NEW
Ever confirmed: true

*** This bug has been marked as a duplicate of 34283 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 5

18 years ago
Marking verified dup of 34283.
Status: RESOLVED → VERIFIED

Updated

29 days ago
Product: Core → Core Graveyard
Component: Layout: HTML Frames → Layout: Images
Product: Core Graveyard → Core
You need to log in before you can comment on or make changes to this bug.