[redux] Make namespaces optional in VM and MMgc codebase

VERIFIED WONTFIX

Status

Tamarin
Virtual Machine
--
enhancement
VERIFIED WONTFIX
10 years ago
9 years ago

People

(Reporter: Rishit Shah, Assigned: Lars T Hansen)

Tracking

(Blocks: 1 bug)

Details

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.4) Gecko/2008102920 Firefox/3.0.4
Build Identifier: 

Replace namespace declarations with macros so that they can be disabled for compilers (like ADS 1.2) that do not support them.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
(Reporter)

Comment 1

10 years ago
Created attachment 350068 [details] [diff] [review]
Patch for changes in files under MMgc [v1]
Attachment #350068 - Flags: review?(treilly)
(Reporter)

Comment 2

10 years ago
Created attachment 350069 [details] [diff] [review]
Patch for changes in files under VM core and shell folders [v1]
Attachment #350069 - Flags: review?(lhansen)
(Assignee)

Comment 3

10 years ago
Comment on attachment 350069 [details] [diff] [review]
Patch for changes in files under VM core and shell folders [v1]

I get a few thousand compilation errors (under Xcode), it looks like many of these are caused by 'uint32' etc not being available all of a sudden.  This is after applying only this patch in isolation, not the patch for MMgc.
Attachment #350069 - Flags: review?(lhansen) → review-
(Assignee)

Comment 4

10 years ago
Created attachment 351365 [details] [diff] [review]
Patch for the entire vm (redux 1188)

Compiles on Mac and Windows, runs test suite on Mac at least.  I'm seeing some sampling crashes in debug builds but I doubt very much that this patch is the cause of that.
Assignee: nobody → lhansen
Attachment #350068 - Attachment is obsolete: true
Attachment #350069 - Attachment is obsolete: true
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #351365 - Flags: review?(rishah)
Attachment #350068 - Flags: review?(treilly)
(Assignee)

Updated

10 years ago
Blocks: 472712
(Assignee)

Updated

9 years ago
Attachment #351365 - Flags: review?(rishah)
(Assignee)

Updated

9 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WONTFIX

Updated

9 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.