Closed Bug 466752 Opened 12 years ago Closed 12 years ago

when closing private browsing session (always on), it asks to save tabs, but doesn't save them

Categories

(Firefox :: Private Browsing, defect)

x86
Linux
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 468565

People

(Reporter: jmaher, Unassigned)

Details

I configure my browser  to be in private browsing mode all the time.  I open up a few tabs, close the browser and get the message if I want to save and quit.  I save, restart, and my tabs are not restored.

I understand if we don't want to support this as it is private browsing, but we should remove the dialog upon closing the browser.
Component: General → Session Restore
QA Contact: general → session.restore
-> Firefox:BrowserGlue
Component: Session Restore → General
QA Contact: session.restore → general
Summary: when closing private browsing session, it asks to save tabs, but doesn't save them → when closing private browsing session (always on), it asks to save tabs, but doesn't save them
hmm I think a better summary would be "Don't ask to restore tabs when private browsing (always-on) is set".
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 468565
Mass moving of all Firefox::General private browsing bugs to Firefox::Private Browsing.
Component: General → Private Browsing
QA Contact: general → private.browsing
You need to log in before you can comment on or make changes to this bug.