This web site does not supply identity information.

VERIFIED DUPLICATE of bug 429021

Status

()

Firefox
General
VERIFIED DUPLICATE of bug 429021
9 years ago
9 years ago

People

(Reporter: Rich F, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.4) Gecko/2008102920 Firefox/3.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.4) Gecko/2008102920 Firefox/3.0.4

When I go to the secure page to book a hotel room on this site that I helped develop and click on the secure lock to view the certificate which BTW we paid a lot of money for to help our buyers confidence level with securing a reservation through the site. I get a message that says: This web site does not supply identity information. and I think it is ****! There should not be any negative statements considering the extent we've gone through to secure our users critical information. There are no negative statements like that on any other browser that I use to access the secure pages so why would Firefox make some sort of negative statement like that?

Reproducible: Always

Steps to Reproduce:
1.If you cannot reproduce it from the link above you may need to access this page: http://www.ineedahotel.com/check_rates.php?hotelID=q6q2tj&name=prava_suites and change your dates preferences so you can get to an actual secure page.
2.
3.
Actual Results:  
I see that statement on almost every secure page that I go to regardless of the site that I go to.

Expected Results:  
I do not expect to see any negative statements on a secure page that we have gone to such a great extent to secure.

Look at what other browsers are saying when you are on a secure page but what your browser is saying does not help with the confidence level that we are trying to create to help our users entrust us with their private information.

Comment 1

9 years ago
Perhaps you are looking to obtain Extended Validation Certificates?
See http://cabforum.org/EV_Certificate_Guidelines_V11.pdf
Having a secure connection to the internet is _nothing_ to do with the identity of the website. Just because you have an encrypted connection to a website does not mean you should trust the website, it means no one can be monitoring your communications with the website.

See http://forums.mozillazine.org/viewtopic.php?p=5022595#p5022595 a good post on this subject.

This bug is not critical, so I've removed that flag, and this subject has been argued to death. I'll find the bug to dupe this against in a moment.
Severity: critical → normal
Version: unspecified → Trunk
Marking this a dupe of bug 429021 (via bug 456986)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 429021
(Reporter)

Comment 4

9 years ago
About this topic:

  -------  Comment #4 From  Rich F   2008-11-26 15:06:30 PST   (-) [reply] -------

How do I go about supplying indentity information to make your insulting
statement go away?

------- Comment #5 From Jesse Ruderman 2008-11-26 15:12:19 PST (-) [reply] -------

Use https.

------- Comment #6 From Rich F 2008-11-26 15:26:05 PST (-) [reply] -------

Ok but if you go to my secure booking page it still says:

Web site: www.blahblah.com
Owner: This web site does not supply identity information.
Verified by: VeriSign, Inc.

So we still have a insulting comment when I click on the secure lock and so
what I am rapidly understanding is that in order to make this insulting comment
to go away and increase my customers trust it isn't just that I need a VeriSign
cert. but that I need a VeriSign EV cert.?

------- Comment #7 From Rich F 2008-11-26 15:43:55 PST (-) [reply] -------

Hello anyone home now? What about my last post?

------- Comment #8 From Eddy Nigg, StartCom Ltd. 2008-11-26 15:55:02 PST (-) [reply] -------

An EV certificate from any provider will show a less insulting comment ;-)

(There are many others besides Verisign, if you prefer)

------- Comment #9 From Rich F 2008-11-26 16:07:24 PST (-) [reply] -------

BTW just for **** and giggles does VeriSign and all the cert sellers that have
various price ranges on the certs. that you can buy from them fund the
development of Firefox?

------- Comment #10 From Rich F 2008-11-26 16:15:17 PST (-) [reply] -------

I see it looks like the old statement that you were innocent until proven
guilty has once again changed to you are guilty until proven innocent and to
clarify it's like this: According to your statement until I get VeriSign or
someone of the likes to make a statement something to the effect that I am who
I say I am according to Firefox you cannot trust that I am who I say I am??? So
I need to pay a lot of money to be who I am. Once again I am guilty until I
prove my innocence. Thank God our real judicial system still believes that I am
innocent until proven guilty. I cannot believe an organization like FF has
bought into the ****!

------- Comment #11 From Rich F 2008-11-26 16:17:46 PST (-) [reply] -------

In reality you could make that statement much less insulting like you used to?
(Reporter)

Updated

9 years ago
Rich, personally, I see nothing insulting about the sign, "This web site does not supply identity information." (I won several sites that say that myself). It simply states that there is no identity information. I also see nothing insulting about anything that was said on this bug. I am asking Gerv to please take a look at this, but I do not think there is any need for you to keep arguing about this. This bug is a dupe of bug 429021.

BTW, Gerv, he posted this same comment on bug 429021.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 6

9 years ago
Maybe you don't have a clue as to what we've done or how much it has costs us to secure that site and attempt to create user trust only to then to click on the secure lock symbol on the browser and have it say anything negative or depreciate our site users trust is appalling to me and it makes several of the site owners not real happy.
You need to log in before you can comment on or make changes to this bug.