Autoconfig file location should include path

RESOLVED WONTFIX

Status

()

Core
AutoConfig (Mission Control Desktop)
--
enhancement
RESOLVED WONTFIX
9 years ago
a year ago

People

(Reporter: Andreas Heinlein, Assigned: mkaply)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; de; rv:1.9.0.4) Gecko/2008111317 Ubuntu/8.04 (hardy) Firefox/3.0.4
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; de; rv:1.9.0.4) Gecko/2008111317 Ubuntu/8.04 (hardy) Firefox/3.0.4

The location of the autoconfig file configured with general.config.filename should allow to include absolute or relative paths, so the .cfg file can be located outside of MOZILLA_INSTALL_DIR. Two reasons:
1. It would be nice to have one site-wide .cfg file on a network drive. As I understood from the guides I've read, sites using autoconfig either distribute their .cfg to all clients or share the whole Firefox installation on the net. Both methods are not always suitable.

2. Autoconfig gets broken on updates at least with several Linux distributions. This is because the install directory moves on update from e.g. /usr/lib/firefox-3.0.3 to /usr/lib/firefox-3.0.4, while the custom .cfg file does not move. This is not a problem of the distribution packaging since configuration data does not belong under /usr in the first place, but under /etc. I see no way for distributions to achieve this without patching firefox.

Reproducible: Always

Steps to Reproduce:
1.Create a site configuration in /etc/firefox/site.cfg
2.Try to put paths within pref("general.config.filename", "/etc/firefox/site.cfg")
Actual Results:  
Firefox ignores the file

Expected Results:  
Firefox reads the file and applies the preferences
(Assignee)

Comment 1

6 years ago
I'll take this since it is a good idea, but there is a workaround/

You can use the preference autoadmin.global_config_url to point to a config file by using a file URL.
Assignee: nobody → mozilla
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Updated

2 years ago
Component: Preferences → AutoConfig (Mission Control Desktop)
Product: Firefox → Core
(Assignee)

Comment 2

a year ago
Upon further thought, we shouldn't allow this.

I'd rather see the autoconfig always in the Firefox directory.

(Plus there is a workaround)
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.