Last Comment Bug 466974 - Implement and advocate CSS3 template-based layout
: Implement and advocate CSS3 template-based layout
Status: RESOLVED DUPLICATE of bug 616605
:
Product: Core
Classification: Components
Component: Layout (show other bugs)
: Trunk
: All All
: -- enhancement with 4 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Jet Villegas (:jet)
Mentors:
http://www.w3.org/TR/css3-layout/
: 468660 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-27 03:41 PST by naught
Modified: 2011-05-25 01:08 PDT (History)
9 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description naught 2008-11-27 03:41:36 PST
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.4) Gecko/2008111318 Ubuntu/8.10 (intrepid) Firefox/3.0.4
Build Identifier: 

Implement CSS3 template-based layout specifiation detailed at
http://www.w3.org/TR/css3-layout/
The spec will finally allow design to be completely separated from the structure of the document (such that many vastly different layouts could be applied to a single document)

And advocate for other major browsers (especially IE, Safari, and Opera) to implement the spec within a limited time-frame. 

The problem with this spec is that it probably won't degrade very gracefully in browsers that it is not implemented in. But if it's not implemented in most people's browsers, it won't be used by the design community. The only way to break this vicious cycle is to have a cross browser agreement on how and when to implement it, and make the time-frame public.

Reproducible: Always
Comment 1 Daniel.S 2008-12-20 05:16:07 PST
*** Bug 468660 has been marked as a duplicate of this bug. ***
Comment 2 Daniel.S 2008-12-20 05:19:17 PST
Well, it's a valid request.

However, because Advanced Layout is still a Working Draft, it got no high priority and you may not see any implementations in the near future.
Comment 3 naught 2008-12-20 15:51:48 PST
Right, I wouldn't expect anyone to rush just for one feature request :)

It would also be good to see the CSS3 Grid layout spec implemented, it seems to be about the same status. Should I open another bug, or modify this one?
Comment 4 Daniel.S 2008-12-21 04:25:21 PST
I'd say let this bug stay as it is. Usually, if the developers want to implement a new feature (especially big ones like grid layouts) they open a new bug anyway, because the original request is full of comments already.

Actually I wouldn't bother reporting any feature that is not in "Candidate Recommendation" status. Working Drafts change too often and contain many issues.

I personally think, the next big thing, web developers will be happy about, are the display:table* types finally introduced by Internet Explorer 8. But I'm starting to ramble on..
Comment 5 aja+bugzilla 2009-11-17 14:04:39 PST
FYI: there's a jQuery implementation now:
http://code.google.com/p/css-template-layout/
In the limited testing I've done, it seems to work pretty well.
Comment 6 Jacob Floyd 2011-05-09 21:46:37 PDT
I suspect that css3-grid-layout (see bug 616605) will supersede/replace css3-layout (this bug). I think implementing css3-grid-layout is a better option. The sooner this is implemented the better. Maybe this bug should be marked as a duplicate of 616605?
Comment 7 naught 2011-05-25 01:08:44 PDT
css3-grid-layout does more or less the same job as the template-based layout in all reasonable use-cases (L-shaped boxes? ouch), and it probably far easier to implement (L-shaped boxes? ouch), and just seems far, far less nutty. The original RFE would have asked for css3-grid-layout, had I known of it. Happy to mark this as a duplicate.

*** This bug has been marked as a duplicate of bug 616605 ***

Note You need to log in before you can comment on or make changes to this bug.