uninitialized local variable warning in xpcwrappedjsclass.cpp

RESOLVED FIXED in mozilla1.9.1b3

Status

()

Core
XPConnect
P1
normal
RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: RyanVM, Assigned: Ben Turner (not reading bugmail, use the needinfo flag!))

Tracking

({fixed1.9.1, regression})

Trunk
mozilla1.9.1b3
fixed1.9.1, regression
Points:
---
Bug Flags:
blocking1.9.1 +

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
c:\mozbuild\mozilla\js\src\xpconnect\src\xpcwrappedjsclass.cpp(302) : warning C4700: uninitialized local variable 'jsexception' used

Caused by the patch for bug 459790
(Reporter)

Updated

9 years ago
Assignee: general → nobody
Component: JavaScript Engine → XPConnect
QA Contact: general → xpconnect
Assignee: nobody → bent.mozilla
Flags: blocking1.9.1?
This is likely to lead to crashes, blocking.
Flags: blocking1.9.1? → blocking1.9.1+
Keywords: regression
Priority: -- → P1
Target Milestone: --- → mozilla1.9.1b3
Created attachment 350863 [details] [diff] [review]
Patch

I continue to hate this rooting stuff...
Attachment #350863 - Flags: superreview?(jst)
Attachment #350863 - Flags: review?(jst)

Updated

9 years ago
Attachment #350863 - Flags: superreview?(jst)
Attachment #350863 - Flags: superreview+
Attachment #350863 - Flags: review?(jst)
Attachment #350863 - Flags: review+

Updated

9 years ago
Duplicate of this bug: 467068
Pushed changeset e437dc52b966 to mozilla-central.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED

Comment 5

9 years ago
This may have caused Bug 468409
Pushed changeset c6c957beb126 to mozilla-1.9.1.
Keywords: fixed1.9.1
(In reply to comment #5)
> This may have caused Bug 468409

It didn't.
You need to log in before you can comment on or make changes to this bug.