If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

even with Sidebar shut, am getting "cannot contact sidebar.cnn.com" error alerts

VERIFIED FIXED

Status

SeaMonkey
Sidebar
P1
normal
VERIFIED FIXED
17 years ago
13 years ago

People

(Reporter: ekrock's old account (dead), Assigned: Steve Lamm)

Tracking

({perf, polish})

Trunk
x86
Windows NT
perf, polish

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3+])

(Reporter)

Description

17 years ago
Using Commercial 2000072508 on WinNT 4.0 SP4.

Expected behavior: If you are running with the sidebar shut, the sidebar panels
should not be attempting to contact the server, and you should not receive
"unable to contact the server sidebar.cnn.com; connection timed out"-type error
alerts

Actual behavior: I'm seeing those alerts, sometimes one from each open window,
all of which have sidebar shut (except for the mail window). This annoys the user.

Note: While typing this bug report, I shut the sidebar panel in my mail window
to see if I still got the errors. Sure enough, after a few minutes, an alert
popped up and a Nav6 window (in which the sidebar panel was shut) rose to the
top of the stack.

Even when I had the mail window open, I don't believe that the mail window's
open sidebar panel was solely to blame here because I recall in the last day or
two having to get rid of one of those alerts from each Nav6 window even though
each one had the sidebar panel shut.
(Reporter)

Comment 1

17 years ago
Nominating nsbeta3 as a polish bug. It interrupts and reduces the user's
productivity to have to dismiss "can't contact server sidebar.cnn.com" alerts
from sidebar panels you've shut.
Keywords: nsbeta3, polish
(Reporter)

Comment 2

17 years ago
Adding perf keyword on suspicion that having all these sidebar panels
duplicatively contacting the server could be burning netlib's time and slowing
down the browser.

Worrisome issues raised by this bug:
1) when sidebar is shut, it shouldn't be contacting the server
2) the sidebar panel in each window should not be duplicating the other's work
(in terms of contacting the server, getting content, etc.)
3) if the sidebar fails to contact the server, it should fail silently rather
than annoying the user with an alert
Keywords: perf

Comment 3

17 years ago
nav triage team:
gotta get this one nailed if possible
Whiteboard: [nsbeta3+]
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
Priority: P3 → P1
(Assignee)

Updated

17 years ago
Whiteboard: [nsbeta3+] → [nsbeta3+] Fix will be to unload hidden tabs. Need to determine if that's too big of a performance hit when switching tabs.
(Assignee)

Updated

17 years ago
Whiteboard: [nsbeta3+] Fix will be to unload hidden tabs. Need to determine if that's too big of a performance hit when switching tabs. → [nsbeta3+] Fix ready. Need review.
(Assignee)

Comment 4

17 years ago
I checked in a fix today. The sidebar tabs load "about:blank" when they are 
hidden.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
Whiteboard: [nsbeta3+] Fix ready. Need review. → [nsbeta3+]

Comment 5

17 years ago
verified that this message is not popping up anymore. (all builds 2000090508m18)
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.