Closed Bug 467638 Opened 13 years ago Closed 13 years ago

run-mozilla.sh should not md5sum core files

Categories

(Firefox Build System :: General, defect)

x86
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
mozilla1.9.1b3

People

(Reporter: dbaron, Assigned: dbaron)

References

Details

(Keywords: fixed1.9.1)

Attachments

(1 file)

Attached patch patchSplinter Review
Right now run-mozilla.sh runs md5sum on any core file when starting up.  This makes Mozilla quite slow to start for any user whose home directory has a large core file.

Given that core files on Linux are now generally called core.$PID, we should probably just remove the "Oh no, we dumped core, do you want to debug it?" code.  This code doesn't make sense for most users; only for developers, and even then it's probably not all that helpful anymore given that it doesn't work with current Linux core file naming and nobody's complained.

However, if we ever add it back, it should use something quick, like stat, rather than md5sum.
Attachment #351050 - Flags: review?(benjamin)
Attachment #351050 - Flags: review?(benjamin) → review+
Fixed on mozilla-central: http://hg.mozilla.org/mozilla-central/rev/9a55fd36efa2
Status: ASSIGNED → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Comment on attachment 351050 [details] [diff] [review]
patch

This is low-risk and I think worth taking on the branch; it helps users who have large core files in their home directory.
Attachment #351050 - Flags: approval1.9.1?
Comment on attachment 351050 [details] [diff] [review]
patch

a191=beltzner
Attachment #351050 - Flags: approval1.9.1? → approval1.9.1+
http://hg.mozilla.org/releases/mozilla-1.9.1/rev/8490dbe99b99
Keywords: fixed1.9.1
Target Milestone: --- → mozilla1.9.1b3
Duplicate of this bug: 456718
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.