Last Comment Bug 467782 - Memory Leak during TopSite Run on http://www.gamespot.com
: Memory Leak during TopSite Run on http://www.gamespot.com
Status: RESOLVED WORKSFORME
[nsDocShell leak (1)]
: mlk, regression
Product: Core
Classification: Components
Component: General (show other bugs)
: Trunk
: x86 Mac OS X
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
http://www.gamespot.com
Depends on:
Blocks: sisyphus-tracking
  Show dependency treegraph
 
Reported: 2008-12-03 09:41 PST by Carsten Book [:Tomcat] - PTO-back Sept 4th
Modified: 2009-04-19 05:57 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
leak log (42.10 KB, text/plain)
2008-12-03 09:41 PST, Carsten Book [:Tomcat] - PTO-back Sept 4th
no flags Details

Description Carsten Book [:Tomcat] - PTO-back Sept 4th 2008-12-03 09:41:15 PST
Created attachment 351203 [details]
leak log

Memory Leak during the automated Global 500 Testrun on http://www.gamespot.com
Deep 0 Testsrun and latest 1.9.1 Mozilla-Central Debug Build - so Frontpage only

Requesting blocking 1.9.1 because its a Website from the Global 500 List.
Also i have not seen this leaks on Testruns before, so this is maybe a
regression.

0 TOTAL                                          29   255364   855456     8120 ( 3524.46 +/-  3623.49)  1243991     4337 ( 2054.11 +/-  3464.62)


nsTraceRefcntImpl::DumpStatistics: 709 entries
nsStringStats
 => mAllocCount:          30524
 => mReallocCount:         2860
 => mFreeCount:           29321  --  LEAKED 1203 !!!
 => mShareCount:          27714
 => mAdoptCount:           3763
 => mAdoptFreeCount:       3760  --  LEAKED 3 !!!

http://www.gamespot.com: EXIT STATUS: NORMAL (15.772634 seconds)
Comment 1 Carsten Book [:Tomcat] - PTO-back Sept 4th 2009-01-28 14:16:25 PST
not seen during the latest run, so i will mark this wfm for now
Comment 2 Shawn Wilsher :sdwilsh 2009-01-28 14:28:13 PST
Likely fixed (at least in part) by bug 473845.

Note You need to log in before you can comment on or make changes to this bug.